summaryrefslogtreecommitdiff
path: root/packages/espeak/espeak_1.35.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/espeak/espeak_1.35.bb')
-rw-r--r--packages/espeak/espeak_1.35.bb21
1 files changed, 12 insertions, 9 deletions
diff --git a/packages/espeak/espeak_1.35.bb b/packages/espeak/espeak_1.35.bb
index 8d7b18a890..f7dacf54bc 100644
--- a/packages/espeak/espeak_1.35.bb
+++ b/packages/espeak/espeak_1.35.bb
@@ -1,19 +1,17 @@
-DESCRIPTION = "eSpeak is a compact open source software speech synthesizer"
-SECTION = "base"
-LICENSE = "GPL"
-DEPENDS = "portaudio-v19"
+require espeak.inc
-PR = "r0"
+EXTRA_PHONEMES = '${@base_contains("SITEINFO_ENDIANESS", "be", "espeak-data (= ${PV})", "", d)}'
+RDEPENDS = "portaudio-v19 ${EXTRA_PHONEMES}"
-SRC_URI = "${SOURCEFORGE_MIRROR}/espeak/espeak-${PV}-source.zip"
+PR = "r1"
-S = "${WORKDIR}/${PN}-${PV}-source"
+CXXFLAGS += "-DUSE_PORTAUDIO"
FILES_${PN} += "${datadir}/espeak-data"
do_configure() {
- # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19
- cp ${S}/src/portaudio19.h ${S}/src/portaudio.h
+ # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19
+ cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
}
do_compile() {
@@ -32,6 +30,11 @@ do_install() {
install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}
oe_libinstall -so -C src libespeak ${D}${libdir}
+ if [ "${SITEINFO_ENDIANESS}" = "be" ] ; then
+ # the big-endian phon* files are provided by the package espeak-data
+ rm -f ${S}/espeak-data/phon*
+ fi
+
cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data
}