summaryrefslogtreecommitdiff
path: root/packages/efl1
diff options
context:
space:
mode:
Diffstat (limited to 'packages/efl1')
-rw-r--r--packages/efl1/ecore.inc8
-rw-r--r--packages/efl1/ecore_cvs.bb4
-rw-r--r--packages/efl1/evas-native_cvs.bb2
-rw-r--r--packages/efl1/evas.inc6
-rw-r--r--packages/efl1/evas_cvs.bb8
-rw-r--r--packages/efl1/ewl_cvs.bb16
6 files changed, 29 insertions, 15 deletions
diff --git a/packages/efl1/ecore.inc b/packages/efl1/ecore.inc
index 86c87214cf..b71a4b7582 100644
--- a/packages/efl1/ecore.inc
+++ b/packages/efl1/ecore.inc
@@ -9,9 +9,11 @@ PV = "0.9.9.041+cvs${SRCDATE}"
inherit efl_library
-SRC_URI += "file://configure.patch;patch=1 \
- file://fix-tslib-configure.patch;patch=1 \
- file://fix-directfb-include.patch;patch=1"
+# SRC_URI += "file://configure.patch;patch=1 \
+# file://fix-tslib-configure.patch;patch=1 \
+# file://fix-directfb-include.patch;patch=1"
+
+SRC_URI += "file://fix-directfb-include.patch;patch=1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/ecore"
diff --git a/packages/efl1/ecore_cvs.bb b/packages/efl1/ecore_cvs.bb
index dd6c467c54..53ee8642d8 100644
--- a/packages/efl1/ecore_cvs.bb
+++ b/packages/efl1/ecore_cvs.bb
@@ -6,8 +6,8 @@ EXTRA_OECONF = "\
--disable-ecore-x-xcb \
--enable-ecore-x \
--enable-ecore-job \
- --enable-ecore-directfb \
- --enable-ecore-sdl \
+ --disable-ecore-directfb \
+ --disable-ecore-sdl \
--enable-ecore-fb \
--enable-ecore-evas \
--disable-ecore-evas-gl \
diff --git a/packages/efl1/evas-native_cvs.bb b/packages/efl1/evas-native_cvs.bb
index 8b8694899e..204abbb821 100644
--- a/packages/efl1/evas-native_cvs.bb
+++ b/packages/efl1/evas-native_cvs.bb
@@ -6,7 +6,7 @@ PR = "r0"
EXTRA_OECONF = "\
--x-includes=${STAGING_INCDIR}/X11 \
--x-libraries=${STAGING_LIBDIR} \
- --disable-fb \
+ --enable-fb \
--disable-directfb \
--disable-sdl \
--enable-buffer \
diff --git a/packages/efl1/evas.inc b/packages/efl1/evas.inc
index 840f2929c5..de3359114c 100644
--- a/packages/efl1/evas.inc
+++ b/packages/efl1/evas.inc
@@ -3,13 +3,13 @@ anti-aliased text, smooth super and sub-images, alpha-blend, as well as drop \
down to using normal X11 primitives such as pixmaps, lines and rectangles if \
your CPU or graphics hardware are too slow."
LICENSE = "MIT"
-# can also depend on valgrind (?)
-DEPENDS = "libsdl-x11 directfb eet freetype jpeg virtual/libx11 libxext"
+# can also depend on valgrind, libsdl-x11, directfb
+DEPENDS = "eet freetype jpeg virtual/libx11 libxext libxrender"
PV = "0.9.9.041+cvs${SRCDATE}"
inherit efl_library
-SRC_URI += "file://fix-configure.patch;patch=1"
+# SRC_URI += "file://fix-configure.patch;patch=1"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/evas"
diff --git a/packages/efl1/evas_cvs.bb b/packages/efl1/evas_cvs.bb
index b80ff8bcba..a19a9c944b 100644
--- a/packages/efl1/evas_cvs.bb
+++ b/packages/efl1/evas_cvs.bb
@@ -1,17 +1,17 @@
require evas.inc
-PR = "r0"
+PR = "r2"
EXTRA_OECONF = "\
--x-includes=${STAGING_INCDIR}/X11 \
--x-libraries=${STAGING_LIBDIR} \
--enable-fb \
- --enable-directfb \
- --enable-sdl \
+ --disable-directfb \
+ --disable-sdl \
--enable-buffer \
--disable-software-ddraw \
--disable-software-qtopia \
--enable-software-x11 \
- --disable-software-16-x11 \
+ --enable-software-16-x11 \
--disable-software-xcb \
--disable-gl-x11 \
--enable-xrender-x11 \
diff --git a/packages/efl1/ewl_cvs.bb b/packages/efl1/ewl_cvs.bb
index 2ac7c65279..8fb8521d62 100644
--- a/packages/efl1/ewl_cvs.bb
+++ b/packages/efl1/ewl_cvs.bb
@@ -1,14 +1,26 @@
DESCRIPTION = "The Enlightened Widget Library, \
a simple-to-use general purpose widget library \
based on the enlightenment foundation libraries."
-DEPENDS = "evas ecore edje emotion efreet"
+DEPENDS = "evas ecore edje emotion efreet epsilon"
RSUGGESTS_${PN} += "ewl-themes"
LICENSE = "MIT"
PV = "0.5.1+cvs${SRCDATE}"
-PR = "r0"
+PR = "r1"
inherit efl_library
+EXTRA_OECONF = "\
+ --enable-software-x11 \
+ --enable-software-16-x11 \
+ --enable-xrender-x11 \
+ --disable-opengl-x11 \
+ --disable-software-xcb \
+ --disable-software-sdl \
+ --enable-framebuffer \
+ --enable-software-buffer \
+ --disable-opengl-glew \
+"
+
# TODO package engines more granular
PACKAGES += "${PN}-plugins ${PN}-engines"