summaryrefslogtreecommitdiff
path: root/packages/efl/evas
diff options
context:
space:
mode:
Diffstat (limited to 'packages/efl/evas')
-rw-r--r--packages/efl/evas/.mtn2git_empty0
-rw-r--r--packages/efl/evas/fix-configure.patch36
-rw-r--r--packages/efl/evas/pagesize.patch13
3 files changed, 0 insertions, 49 deletions
diff --git a/packages/efl/evas/.mtn2git_empty b/packages/efl/evas/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/efl/evas/.mtn2git_empty
+++ /dev/null
diff --git a/packages/efl/evas/fix-configure.patch b/packages/efl/evas/fix-configure.patch
deleted file mode 100644
index abf9b94bdf..0000000000
--- a/packages/efl/evas/fix-configure.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-diff -Nur evas-0.9.9.037~/configure.in evas-0.9.9.037/configure.in
---- evas-0.9.9.037~/configure.in 2007-01-14 20:09:57.000000000 -0800
-+++ evas-0.9.9.037/configure.in 2007-01-14 20:11:09.000000000 -0800
-@@ -161,9 +161,7 @@
- AC_CHECK_HEADER(X11/X.h,
- [
- AC_DEFINE(BUILD_ENGINE_SOFTWARE_X11, 1, [Software X11 Rendering Backend])
-- x_dir=${x_dir:-/usr/X11R6}
-- x_cflags=${x_cflags:--I${x_includes:-$x_dir/include}}
-- x_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} -lX11 -lXext"
-+ x_libs="-lX11 -lXext"
- ],
- [
- AC_MSG_RESULT(disabling software X11 engine)
-@@ -407,10 +405,10 @@
- AC_DEFINE(BUILD_ENGINE_GL_X11, 1, [OpenGL X11 Rendering Backend])
- AM_CONDITIONAL(BUILD_ENGINE_GL_COMMON, true)
- AC_DEFINE(BUILD_ENGINE_GL_COMMON, 1, [Generic OpenGL Rendering Support])
-- x_dir=${x_dir:-/usr/X11R6};
-+ x_dir=${x_dir:-};
- x_cflags=${x_cflags:--I$x_dir/include}
- x_libs="${x_libs:--L$x_dir/lib -lX11 -lXext}"
-- gl_cflags="-I/usr/include"
-+ gl_cflags=""
- gl_libs="-lGL -lGLU -lpthread"
- gl_dir=""
- ], [
-@@ -471,7 +469,7 @@
- AC_DEFINE(BUILD_ENGINE_CAIRO_X11, 1, [Cairo X11 Rendering Backend])
- AM_CONDITIONAL(BUILD_ENGINE_CAIRO_COMMON, true)
- AC_DEFINE(BUILD_ENGINE_CAIRO_COMMON, 1, [Generic Cairo Rendering Support])
-- x_dir="/usr/X11R6";
-+ x_dir="";
- x_cflags="-I"$x_dir"/include"
- x_libs="-L"$x_dir"/lib -lX11 -lXext"
- ], [
diff --git a/packages/efl/evas/pagesize.patch b/packages/efl/evas/pagesize.patch
deleted file mode 100644
index 5efd16a96e..0000000000
--- a/packages/efl/evas/pagesize.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/src/modules/engines/fb/evas_fb_main.c b/src/modules/engines/fb/evas_fb_main.c
-index e26c171..75e0743 100644
---- a/src/modules/engines/fb/evas_fb_main.c
-+++ b/src/modules/engines/fb/evas_fb_main.c
-@@ -530,7 +530,7 @@ fb_postinit(FB_Mode *mode)
- fb_cleanup();
- exit(1);
- }
-- mode->mem_offset = (unsigned)(fb_fix.smem_start) & (~PAGE_MASK);
-+ mode->mem_offset = (unsigned)(fb_fix.smem_start) & (getpagesize()-1);
- mode->mem = (unsigned char *)mmap(NULL, fb_fix.smem_len + mode->mem_offset,
- PROT_WRITE | PROT_READ, MAP_SHARED, fb, 0);
- if ((int)mode->mem == -1)