summaryrefslogtreecommitdiff
path: root/packages/eet/eet_cvs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/eet/eet_cvs.bb')
-rw-r--r--packages/eet/eet_cvs.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/eet/eet_cvs.bb b/packages/eet/eet_cvs.bb
new file mode 100644
index 0000000000..bcdb8e7366
--- /dev/null
+++ b/packages/eet/eet_cvs.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "EET is a tiny library designed to write an \
+arbitary set of chunks of data to a file and optionally compress \
+each chunk (very much like a zip file) and allow fast \
+random-access reading of the file later on."
+HOMEPAGE = "http://www.enlightenment.org"
+MAINTAINER = "Carsten Haitzler (Rasterman) <raster@rasterman.com>"
+SECTION = "e/libs"
+PRIORITY = "optional"
+DEPENDS = "zlib jpeg"
+
+PR = "1"
+
+do_prepsources () {
+ make clean distclean || true
+}
+addtask prepsources after do_fetch before do_unpack
+
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net:/cvsroot/enlightenment;module=eet"
+
+S = "${WORKDIR}/eet"
+
+inherit autotools pkgconfig binconfig
+
+do_stage () {
+ bb_libinstall -C src/lib libeet ${STAGING_LIBDIR}/
+ install -m 0644 ${S}/src/lib/Eet.h ${STAGING_INCDIR}/
+}
+
+FILES_${PN} = "${libdir}/libeet*.so*"
+FILES_${PN}-dev += "${bindir} ${libdir}/pkgconfig"