summaryrefslogtreecommitdiff
path: root/packages/e17/e-wm/fix-configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'packages/e17/e-wm/fix-configure.patch')
-rw-r--r--packages/e17/e-wm/fix-configure.patch54
1 files changed, 54 insertions, 0 deletions
diff --git a/packages/e17/e-wm/fix-configure.patch b/packages/e17/e-wm/fix-configure.patch
new file mode 100644
index 0000000000..d2ee47e014
--- /dev/null
+++ b/packages/e17/e-wm/fix-configure.patch
@@ -0,0 +1,54 @@
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- e/configure.in~fix-configure.patch
++++ e/configure.in
+@@ -114,9 +114,7 @@
+ AC_PATH_XTRA
+ AC_CHECK_HEADER(X11/X.h,
+ [
+- x_dir=${x_dir:-/usr/X11R6}
+- x_cflags=${x_cflags:--I${x_includes:-$x_dir/include}}
+- x_libs="${x_libs:--L${x_libraries:-$x_dir/lib}} -lX11 -lXext"
++ x_libs="-lX11 -lXext";
+ ],[
+ AC_MSG_ERROR([Cannot find X headers and libraries.])
+ ]
+--- e/src/bin/Makefile.am~fix-configure.patch
++++ e/src/bin/Makefile.am
+@@ -1,6 +1,5 @@
+ MAINTAINERCLEANFILES = Makefile.in
+-INCLUDES = -I$(includedir) \
+- -I$(top_srcdir) \
++INCLUDES = -I$(top_srcdir) \
+ -I$(top_srcdir)/src/bin \
+ -I$(top_srcdir)/src/lib \
+ @e_cflags@ \
+--- e/src/lib/Makefile.am~fix-configure.patch
++++ e/src/lib/Makefile.am
+@@ -1,6 +1,5 @@
+ MAINTAINERCLEANFILES = Makefile.in
+-INCLUDES = -I$(includedir) \
+- -I$(top_srcdir)/src/bin \
++INCLUDES = -I$(top_srcdir)/src/bin \
+ @ecore_cflags@ \
+ @evas_cflags@
+
+--- e/src/preload/Makefile.am~fix-configure.patch
++++ e/src/preload/Makefile.am
+@@ -2,7 +2,6 @@
+
+ INCLUDES = -I. \
+ -I$(top_srcdir) \
+- -I$(includedir) \
+ -I$(top_srcdir)src/preload \
+ @x_cflags@
+ pkgdir = $(libdir)/enlightenment/preload
+--- e/src/Makefile.am~fix-configure.patch
++++ e/src/Makefile.am
+@@ -1,2 +1,2 @@
+ MAINTAINERCLEANFILES = Makefile.in
+-SUBDIRS = bin modules lib preload
++SUBDIRS = bin modules preload