summaryrefslogtreecommitdiff
path: root/packages/directfb/dfb++_0.9.23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'packages/directfb/dfb++_0.9.23.bb')
-rw-r--r--packages/directfb/dfb++_0.9.23.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/directfb/dfb++_0.9.23.bb b/packages/directfb/dfb++_0.9.23.bb
new file mode 100644
index 0000000000..0e0772da94
--- /dev/null
+++ b/packages/directfb/dfb++_0.9.23.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "A C++ Wrapper for the directfb framebuffer library."
+HOMEPAGE = "http://directfb.org"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "directfb"
+LICENSE = "LGPL"
+
+# needs a g++4 patch
+BROKEN = "1"
+
+SRC_URI = "http://www.directfb.org/downloads/Extras/DFB++-${PV}.tar.gz"
+S = "${WORKDIR}/DFB++-${PV}"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_runmake -C include 'libdir=/lib' 'includedir=/include/dfb++' \
+ 'oldincludedir=/include' 'datadir=/share' \
+ 'DESTDIR=${STAGING_LIBDIR}/..' \
+ install-dfbppincludeHEADERS
+ oe_runmake -C dfb++ 'libdir=/lib' 'includedir=/include/dfb++' \
+ 'oldincludedir=/include' 'datadir=/share' \
+ 'DESTDIR=${STAGING_LIBDIR}/..' \
+ install-libLTLIBRARIES
+}
+
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+}