summaryrefslogtreecommitdiff
path: root/recipes/xml-commons/xpp2_2.1.10.bb
diff options
context:
space:
mode:
authorRobert Schuster <robertschuster@fsfe.org>2009-09-18 16:04:01 +0200
committerRobert Schuster <robertschuster@fsfe.org>2009-09-18 16:04:01 +0200
commit2e7c334a4f6b0882ee90c8be91f81d24e4d82496 (patch)
tree11c29c8c61eb8679015869fea7aab5e51cd8eec7 /recipes/xml-commons/xpp2_2.1.10.bb
parent04800cfdf823ea3003eb1164c4d5dfd7e1db5679 (diff)
dom4j 1.6.1: New recipe (for Jalimo SVN).
dom4j-native 1.6.1: Dito. jaxen 1.1.1: Dito. xom 1.1: Dito. xpp2 2.1.10: Dito. xpp3 1.1.3.4.0: Dito.
Diffstat (limited to 'recipes/xml-commons/xpp2_2.1.10.bb')
-rw-r--r--recipes/xml-commons/xpp2_2.1.10.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/recipes/xml-commons/xpp2_2.1.10.bb b/recipes/xml-commons/xpp2_2.1.10.bb
new file mode 100644
index 0000000000..0321ea65fa
--- /dev/null
+++ b/recipes/xml-commons/xpp2_2.1.10.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "Streaming pull XML parser for java"
+LICENSE = "BSD-like"
+
+HOMEPAGE = "http://www.extreme.indiana.edu/xgws/xsoap/xpp/"
+
+SRC_URI = "http://www.extreme.indiana.edu/xgws/xsoap/xpp/download/PullParser2/PullParser2.1.10.tgz"
+
+S = "${WORKDIR}/PullParser${PV}"
+
+inherit java-library
+
+DEPENDS = "fastjar-native virtual/javac-native"
+
+do_compile() {
+ if [ -d build-oe ]; then
+ rm -rf build-oe
+ fi
+ mkdir -p build-oe
+
+ sourcepath="src/java/drivers/jaxp11:src/java/drivers/sax2:src/java/impl/factory:src/java/impl/format:src/java/impl/node:src/java/impl/pullparser:src/java/impl/tag:src/java/intf"
+
+ findpath="${sourcepath//:/ }"
+
+ javac -sourcepath $sourcepath -d build-oe `find $findpath -name "*.java"`
+
+ mkdir -p build-oe/META-INF/services
+ cp src/java/drivers/jaxp11/META-INF/services/javax.xml.parsers.SAXParserFactory build-oe/META-INF/services
+ cp src/java/impl/factory/META-INF/services/org.gjt.xpp.XmlPullParserFactory build-oe/META-INF/services
+
+ fastjar -C build-oe -c -f ${JARFILENAME} .
+}