summaryrefslogtreecommitdiff
path: root/recipes/vnc/libvncserver_0.9.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
commit6a21d65d2840c58cfa7cd749a04669d8f7980646 (patch)
tree00b1aa153b69cda8cf9406c4700fd7730c34d3a5 /recipes/vnc/libvncserver_0.9.bb
parentdcfe7349b369a87881cf1fa43085d9e9c5609fcf (diff)
parent6f854d71c347475d53d5080a5490625345d95d12 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/vnc/libvncserver_0.9.bb')
-rw-r--r--recipes/vnc/libvncserver_0.9.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes/vnc/libvncserver_0.9.bb b/recipes/vnc/libvncserver_0.9.bb
new file mode 100644
index 0000000000..7aca752c0b
--- /dev/null
+++ b/recipes/vnc/libvncserver_0.9.bb
@@ -0,0 +1,32 @@
+DESCRIPTION = "A library to support implementations of RDP/VNC servers"
+AUTHOR = "Johannes Schindelin <dscho@users.sourceforge.net>"
+HOMEPAGE = "http://sourceforge.net/projects/libvncserver"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+DEPENDS = "virtual/libsdl virtual/libx11 zlib jpeg libxext"
+PROVIDES = "x11vnc"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libvncserver/LibVNCServer-${PV}.tar.gz"
+S = "${WORKDIR}/LibVNCServer-${PV}"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install_append() {
+ install -d ${D}${bindir}
+ install -m 0755 examples/storepasswd ${D}${bindir}
+ install -d ${D}${datadir}/fbvncserver/classes
+ install -m 0644 classes/index.vnc ${D}${datadir}/fbvncserver/classes/
+ install -m 0644 classes/VncViewer.jar ${D}${datadir}/fbvncserver/classes/
+}
+
+PACKAGES =+ "x11vnc libvncserver-storepasswd libvncserver-javaapplet"
+FILES_x11vnc = "${bindir}/x11vnc ${bindir}/LinuxVNC"
+FILES_libvncserver-storepasswd = "${bindir}/storepasswd"
+FILES_libvncserver-javaapplet = "${datadir}/fbvncserver/classes/index.vnc \
+ ${datadir}/fbvncserver/classes/VncViewer.jar"