summaryrefslogtreecommitdiff
path: root/recipes/vdr/vdr_1.7.10.bb
diff options
context:
space:
mode:
authorSergey Lapin <slapin@ossfans.org>2010-01-22 00:50:27 +0300
committerSergey Lapin <slapin@ossfans.org>2010-01-22 00:50:27 +0300
commit029e21c8111deafa850ad1724e48da29c321f2f8 (patch)
tree00c9ad7db155d3f3fe471517d5d882b517f9ccfd /recipes/vdr/vdr_1.7.10.bb
parent8e099432e6b3687bc97f756aa7176b02cb1c7693 (diff)
parentb6f9a84fd99c89ac074aaed90cdd3d064c534492 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/vdr/vdr_1.7.10.bb')
-rw-r--r--recipes/vdr/vdr_1.7.10.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/vdr/vdr_1.7.10.bb b/recipes/vdr/vdr_1.7.10.bb
new file mode 100644
index 0000000000..a8fa82c13b
--- /dev/null
+++ b/recipes/vdr/vdr_1.7.10.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Video Disk Recorder (VDR) is a digital sat-receiver program using Linux and DVB technologies. It allows one to record MPEG2 streams, as well as output the stream to TV. It is also possible to watch DVDs (hardware accelerated) with some comfort and use an IR remote control."
+AUTHOR = "Klaus Schmidinger"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://www.tvdr.de"
+PR = "r2"
+
+DEPENDS = "fontconfig freetype gettext libcap jpeg virtual/libintl"
+
+SRC_URI = "ftp://ftp.tvdr.de/vdr/Developer/${P}.tar.bz2 \
+ file://fixpaths.patch;patch=1 \
+ file://cplusplus.patch;patch=1 \
+ file://disable_plugin.patch;patch=1 \
+ file://linkerflags.patch;patch=1 \
+ "
+
+SRC_URI_append_linux-uclibceabi = " file://libintl.patch;patch=1 "
+SRC_URI_append_uclinux-uclibc = " file://libintl.patch;patch=1 "
+
+CFLAGS_append += " -I${STAGING_INCDIR}/freetype2"
+
+PLUGINDIR = "${libdir}/vdr/plugins"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' \
+ 'PREFIX=${prefix}' \
+ 'CONFDIR=${sysconfdir}/vdr' \
+ 'VIDEODIR=/var/lib/vdr/video' \
+ 'PLUGINLIBDIR=${PLUGINDIR}' \
+ 'LOCDIR=${datadir}/locale' \
+ install
+}
+
+PACKAGES_DYNAMIC += "vdr-plugin-*"
+
+python populate_packages_prepend () {
+ plugindir = bb.data.expand('${PLUGINDIR}', d)
+ do_split_packages(d, plugindir, '^libvdr-(.*)\.so*', 'libvdr-%s', 'vdr plugin %s', extra_depends='')
+}
+
+FILES_${PN} = "${bindir}/* /var/lib/vdr/conf/* ${sysconfdir}/*"
+FILES_${PN}-dbg += "${PLUGINDIR}/.debug/*"
+