summaryrefslogtreecommitdiff
path: root/recipes/upslug/upslug-native_1.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/upslug/upslug-native_1.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/upslug/upslug-native_1.0.bb')
-rw-r--r--recipes/upslug/upslug-native_1.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/upslug/upslug-native_1.0.bb b/recipes/upslug/upslug-native_1.0.bb
new file mode 100644
index 0000000000..02c41eb42b
--- /dev/null
+++ b/recipes/upslug/upslug-native_1.0.bb
@@ -0,0 +1,28 @@
+# This package builds the 'upslug' binary upload/flash tool
+# for the NSLU2. It is not useful for anything else.
+PR = "r1"
+DESCRIPTION = "NSLU2 binary upload tool"
+HOMEPAGE = "http://www.nslu2-linux.org/wiki/Main/UpSlug"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "GPLv2"
+COMPATIBLE_MACHINE = "nslu2"
+
+SRC_TAG = "UPSLUG_${@'_'.join(bb.data.getVar('PV',d,1).split('.'))}"
+SRC_URI = "cvs://anonymous@nslu.cvs.sourceforge.net/cvsroot/nslu;method=pserver;module=upslug;tag=${SRC_TAG}"
+# For testing use this (tags and other changes take a day to
+# propogate on sourceforge). Change 'jbowler' to your login name!
+#SRC_URI = "cvs://jbowler@cvs.sourceforge.net/cvsroot/nslu;method=ext;rsh=ssh;tag=${SRC_TAG};module=upslug"
+
+inherit native
+
+S = "${WORKDIR}/upslug"
+
+# Dumb compile script
+do_compile() {
+ oe_runmake "CC=${CC}" "CFLAGS=${CFLAGS}"
+}
+
+do_stage() {
+ oe_runmake "DESTDIR=${STAGING_BINDIR}" install
+}