summaryrefslogtreecommitdiff
path: root/recipes/u-boot/u-boot_git.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/u-boot/u-boot_git.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/u-boot/u-boot_git.bb')
-rw-r--r--recipes/u-boot/u-boot_git.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
new file mode 100644
index 0000000000..e5a8d5d327
--- /dev/null
+++ b/recipes/u-boot/u-boot_git.bb
@@ -0,0 +1,60 @@
+require u-boot.inc
+PR ="r22"
+
+SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git "
+SRCREV_davinci-sffsdr = "4b50cd12a3b3c644153c4cf393f4a4c12289e5aa"
+SRCREV_davinci-dvevm = "4b50cd12a3b3c644153c4cf393f4a4c12289e5aa"
+SRCREV_akita = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
+SRCREV_spitz = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
+SRCREV_c7x0 = "9bf86baaa3b35b25baa2d664e2f7f6cafad689ee"
+SRCREV_afeb9260 = "2077e348c2a84901022ad95311b47b70361e6daa"
+
+SRC_URI_beagleboard = "git://www.sakoman.net/git/u-boot-omap3.git;branch=omap3-dev;protocol=git"
+SRCREV_beagleboard = "b7038cff739684bb95853eb5bee924c2574a222e"
+PV_beagleboard = "2008.10+${PR}+gitr${SRCREV}"
+
+SRC_URI_omap3evm = "git://www.sakoman.net/git/u-boot-omap3.git;branch=omap3;protocol=git"
+SRCREV_omap3evm = "1e329ec630b31803ee191d2ee335214662b5bfea"
+PV_omap3evm = "2008.10+${PR}+gitr${SRCREV}"
+
+SRC_URI_omapzoom = "git://www.sakoman.net/git/u-boot-omap3.git;branch=omap3-dev;protocol=git"
+SRCREV_omapzoom = "d691b424f1f5bf7eea3a4131dfc578d272e8f335"
+PV_omapzoom = "2009.01+${PR}+gitr${SRCREV}"
+
+SRC_URI_neuros-osd2 = "git://github.com/neuros/u-boot.git;protocol=git;branch=neuros"
+SRCREV_neuros-osd2 = "8de979d346624c0e4cfe2e5c0f08ce20ca4b5d14"
+
+SRC_URI_sequoia = "git://www.denx.de/git/u-boot.git;protocol=git"
+SRCREV_sequoa = "cf3b41e0c1111dbb865b6e34e9f3c3d3145a6093"
+
+SRC_URI = "git://www.denx.de/git/u-boot.git;protocol=git "
+SRC_URI_sequoia = "git://www.denx.de/git/u-boot.git;protocol=git;tag=cf3b41e0c1111dbb865b6e34e9f3c3d3145a6093 "
+
+SRC_URI_neuros-osd2 += "file://Makefile-fix.patch;patch=1"
+SRC_URI_append_akita = "file://pdaXrom-u-boot.patch;patch=1 \
+ file://uboot-eabi-fix-HACK2.patch;patch=1 \
+ file://akita-standard-partitioning.patch;patch=1 \
+ "
+SRC_URI_append_spitz = "file://pdaXrom-u-boot.patch;patch=1 \
+ file://uboot-eabi-fix-HACK2.patch;patch=1 \
+ file://spitz-standard-partitioning.patch;patch=1 \
+ "
+SRC_URI_append_c7x0 = "file://pdaXrom-u-boot.patch;patch=1 \
+ file://uboot-eabi-fix-HACK2.patch;patch=1 \
+ file://corgi-standard-partitioning.patch;patch=1 \
+ "
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_configure_prepend_akita() {
+ sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/akita.h
+}
+
+do_configure_prepend_spitz() {
+ sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/akita.h
+}
+
+do_configure_prepend_c7x0() {
+ sed -i s:ROOT_FLASH_SIZE:${ROOT_FLASH_SIZE}:g ${S}/include/configs/corgi.h
+}