summaryrefslogtreecommitdiff
path: root/recipes/u-boot/u-boot_1.2.0.bb
diff options
context:
space:
mode:
authorChris Larson <chris_larson@mentor.com>2010-05-23 20:23:53 -0700
committerChris Larson <chris_larson@mentor.com>2010-05-25 12:53:41 -0700
commitbf7d0467a0788a7fcc1c96e0dc35a25ae09278a0 (patch)
tree96f28e2f5133d68c3e3dadabaa2339340671454f /recipes/u-boot/u-boot_1.2.0.bb
parentfab0af3aefee22b21541e403d3c356a6979bfa63 (diff)
Rename url params patch=<ignored>/pnum=<n> to apply={yes,no}/striplevel=<n>
I think this makes the behavior rather more clear. Signed-off-by: Chris Larson <chris_larson@mentor.com> Acked-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/u-boot/u-boot_1.2.0.bb')
-rw-r--r--recipes/u-boot/u-boot_1.2.0.bb40
1 files changed, 20 insertions, 20 deletions
diff --git a/recipes/u-boot/u-boot_1.2.0.bb b/recipes/u-boot/u-boot_1.2.0.bb
index e4b0efc5a7..0469f042c4 100644
--- a/recipes/u-boot/u-boot_1.2.0.bb
+++ b/recipes/u-boot/u-boot_1.2.0.bb
@@ -4,17 +4,17 @@ PR = "r3"
SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-1.2.0.tar.bz2 \
"
-SRC_URI_append_turbostation = "file://qnap.diff;patch=1"
+SRC_URI_append_turbostation = "file://qnap.diff;apply=yes"
-SRC_URI_append_lsppchg = "file://u-boot-kurobox.patch;patch=1 \
- file://u-boot-kurobox-fdt.patch;patch=1 \
+SRC_URI_append_lsppchg = "file://u-boot-kurobox.patch;apply=yes \
+ file://u-boot-kurobox-fdt.patch;apply=yes \
file://defconfig_lsppchg"
-SRC_URI_append_lsppchd = "file://u-boot-kurobox.patch;patch=1 \
- file://u-boot-kurobox-fdt.patch;patch=1 \
+SRC_URI_append_lsppchd = "file://u-boot-kurobox.patch;apply=yes \
+ file://u-boot-kurobox-fdt.patch;apply=yes \
file://defconfig_lsppchg"
-SRC_URI_append_dm355-leopard = " file://dm355-leopard.diff;patch=1"
+SRC_URI_append_dm355-leopard = " file://dm355-leopard.diff;apply=yes"
do_compile_prepend_lsppchg () {
cp ${WORKDIR}/defconfig_lsppchg ${S}/include/configs/linkstation.h
@@ -25,20 +25,20 @@ do_compile_prepend_lsppchd () {
}
SRC_URI_append_mpc8315e-rdb = " \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-pre.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-soc.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-PHY.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-platform.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-nand-controller.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-nand-boot.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-serdes.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-pcie.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-fsl-1.3.0-MPC83xx-CW.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-silicon-1.1-1.2.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-extra-config-for-333-266MHz.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-resume-deep-sleep.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-improve-ddr-performance.patch;patch=1 \
-http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-fix-PCI-IO-base.patch;patch=1 \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-pre.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-soc.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-PHY.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-platform.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-nand-controller.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-nand-boot.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-serdes.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-pcie.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-fsl-1.3.0-MPC83xx-CW.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-silicon-1.1-1.2.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-extra-config-for-333-266MHz.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-resume-deep-sleep.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-improve-ddr-performance.patch;apply=yes \
+http://www.bitshrine.org/gpp/u-boot-1.2.0-mpc8315erdb-fix-PCI-IO-base.patch;apply=yes \
"