summaryrefslogtreecommitdiff
path: root/recipes/u-boot/u-boot_1.1.4.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/u-boot/u-boot_1.1.4.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/u-boot/u-boot_1.1.4.bb')
-rw-r--r--recipes/u-boot/u-boot_1.1.4.bb71
1 files changed, 71 insertions, 0 deletions
diff --git a/recipes/u-boot/u-boot_1.1.4.bb b/recipes/u-boot/u-boot_1.1.4.bb
new file mode 100644
index 0000000000..df6a357c63
--- /dev/null
+++ b/recipes/u-boot/u-boot_1.1.4.bb
@@ -0,0 +1,71 @@
+require u-boot.inc
+
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
+ file://u-boot-make381-fix.patch;patch=1"
+
+SRC_URI_append_gumstix = "\
+ file://u-boot-autoscript.patch;patch=1 \
+ file://u-boot-base.patch;patch=1 \
+ file://u-boot-crc-warning-not-so-scary.patch;patch=1 \
+ file://u-boot-flash-protect-fixup.patch;patch=1 \
+ file://u-boot-fw_printenv.patch;patch=1 \
+ file://u-boot-install.patch;patch=1 \
+ file://u-boot-jerase-cmd.patch;patch=1 \
+ file://u-boot-jffs2-new-nodetypes.patch;patch=1 \
+ file://u-boot-loadb-safe.patch;patch=1 \
+ file://u-boot-mmc-init.patch;patch=1 \
+ file://u-boot-mmcclk-alternate.patch;patch=1 \
+ file://u-boot-smc91x-multi.patch;patch=1 \
+ file://u-boot-zzz-osx.patch;patch=1"
+
+SRC_URI_append_amsdelta = "\
+ http://the.earth.li/pub/e3/u-boot-amsdelta-20060519.diff;patch=1"
+
+SRC_URI_append_dht-walnut= "\
+ file://u-boot-dht-walnut-df2.patch;patch=1"
+
+SRC_URI_append_avr32= "\
+ http://avr32linux.org/twiki/pub/Main/UbootPatches/u-boot-1.1.4-avr1.patch.bz2;patch=1 \
+ file://avr32-boards-fix-flash-read.patch;patch=1 \
+ file://lcdc-driver-for-avr32.patch;patch=1 \
+ file://spi-driver-for-avr32.patch;patch=1 \
+ file://at32ap-add-framebuffer-address.patch;patch=1 \
+ file://at32ap-add-spi-initcalls.patch;patch=1 \
+ file://at32ap-add-system-manager-header-file.patch;patch=1 \
+ file://ap7000-add-spi-device-and-lcdc-base-address.patch;patch=1 \
+ file://libavr32-add-spi-and-lcd-board-support.patch;patch=1 \
+ file://cmd-bmp-add-gzip-compressed-bmp.patch;patch=1 \
+ file://lcd-add-24-bpp-support-and-atmel-lcdc-support.patch;patch=1 \
+ file://atstk1000-spi-support.patch;patch=1 \
+ file://atstk1000-ltv350qv-display-support.patch;patch=1 \
+ file://atstk1000-add-lcd-and-spi-to-config.patch;patch=1 \
+ file://at32ap-add-define-for-sdram-test.patch;patch=1 \
+ file://fix-mmc-data-timeout.patch;patch=1 \
+"
+
+EXTRA_OEMAKE_gumstix = "CROSS_COMPILE=${TARGET_PREFIX} GUMSTIX_400MHZ=${GUMSTIX_400MHZ}"
+TARGET_LDFLAGS = ""
+
+UBOOT_MACHINE_dht-walnut = "walnut_config"
+UBOOT_MACHINE_atngw100 = "atngw_config"
+
+def gumstix_mhz(d):
+ import bb
+ m = bb.data.getVar('GUMSTIX_400MHZ', d, 1)
+ if 'y' == m:
+ return '400'
+ else:
+ return '200'
+
+UBOOT_IMAGE_gumstix = "u-boot-${MACHINE}-${@gumstix_mhz(d)}Mhz-${PV}-${PR}.bin"
+
+inherit base
+
+do_compile () {
+ oe_runmake ${UBOOT_MACHINE}
+ oe_runmake all
+}