summaryrefslogtreecommitdiff
path: root/recipes/txdrug/txdrug_0.1.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/txdrug/txdrug_0.1.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/txdrug/txdrug_0.1.bb')
-rw-r--r--recipes/txdrug/txdrug_0.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/txdrug/txdrug_0.1.bb b/recipes/txdrug/txdrug_0.1.bb
new file mode 100644
index 0000000000..31da8117f7
--- /dev/null
+++ b/recipes/txdrug/txdrug_0.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Tx Drug Database"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "sqlite"
+PR = "r3"
+
+SRC_URI = "http://teax.sourceforge.net/txdrug-${PV}.tar.gz \
+ file://${FILESDIR}/opt/QtPalmtop"
+S = "${WORKDIR}/txdrug-tar"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += "LIBS+=-lsqlite TARGET=txdrug"
+
+do_configure_prepend() {
+ rm -f Makefile && qmake -project
+}
+
+do_configure_append() {
+ sed -i "s/\-I\/usr\/include\/sqlite\ //g" Makefile
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}
+ cp -Pfr `ls -dp ${WORKDIR}/opt/QtPalmtop/*|grep -v SCCS` ${D}${palmtopdir}/
+ install -D -m 755 txdrug ${D}${palmtopdir}/bin/txdrug
+}
+