summaryrefslogtreecommitdiff
path: root/recipes/ti/ti-dmai_2.10.00.10.bb
diff options
context:
space:
mode:
authorBrijesh Singh <bksingh@ti.com>2010-05-08 10:22:19 -0500
committerKoen Kooi <koen@openembedded.org>2010-06-12 11:03:49 +0200
commit9b4d135a4e335350f7dc0d3004cb1588dcd74e99 (patch)
tree225b80f4e9e5474551d735276a8f89078b4e3227 /recipes/ti/ti-dmai_2.10.00.10.bb
parentdb950b803cc2a6d3a6b63af7d57fc037b3286d54 (diff)
ti-dmai_2.10.00.xx: add recipe to build released dmai versions
* run dmai release steps in do_install_prepend() * apply dmai DM365 resizer patch needed for gstreamer TIVidResizer element. * update dm365 loadmodule.sh Signed-off-by: Brijesh Singh <bksingh@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti/ti-dmai_2.10.00.10.bb')
-rw-r--r--recipes/ti/ti-dmai_2.10.00.10.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/ti/ti-dmai_2.10.00.10.bb b/recipes/ti/ti-dmai_2.10.00.10.bb
new file mode 100644
index 0000000000..66cc424d7c
--- /dev/null
+++ b/recipes/ti/ti-dmai_2.10.00.10.bb
@@ -0,0 +1,22 @@
+require ti-dmai.inc
+
+PV = "2_10_00_10"
+PR = "r2"
+
+COMPATIBLE_MACHINE = "(dm365-evm|dm355-evm|dm6467-evm)"
+
+SRC_URI_append = "file://0001-Correct-DMAI-s-Resize-module-for-DM365.patch;patch=3 \
+ file://doxygen_templates.tar.gz \
+ file://arago-tdox"
+
+SRCREV = "452"
+DMAIBRANCH = "branches/GITPSP_INT_101009"
+
+do_install_prepend () {
+ find ${S} -name .svn -type d | xargs rm -rf
+ cp -pPrf ${WORKDIR}/doxygen_templates ${S}
+ cp -pPrf ${WORKDIR}/arago-tdox ${S}/tdox
+ chmod a+x ${S}/release.sh
+ chmod a+x ${S}/tdox
+ ${S}/release.sh ${PV}
+}