summaryrefslogtreecommitdiff
path: root/recipes/ti/matrix-gui-e_svn.bb
diff options
context:
space:
mode:
authorChase Maupin <chase.maupin@ti.com>2010-05-27 10:51:44 -0500
committerKoen Kooi <koen@openembedded.org>2010-05-28 09:21:13 +0200
commita9172ffa7ae4408c176b4b5643fd70a69411114b (patch)
tree5869647cbf0e3d14381d949487abd51266f18e59 /recipes/ti/matrix-gui-e_svn.bb
parentb4aa462e12b2c2920fc364581186b6c5b48424bd (diff)
matrix-gui-e_svn: Renamed matrix-gui_svn
* Renamed the matrix-gui_svn recipe to matrix-gui-e_svn to be more in line with naming conventions of other applications. This is in preparation for making and X11 version of the recipe. * Moved associated files Acked-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
Diffstat (limited to 'recipes/ti/matrix-gui-e_svn.bb')
-rw-r--r--recipes/ti/matrix-gui-e_svn.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/recipes/ti/matrix-gui-e_svn.bb b/recipes/ti/matrix-gui-e_svn.bb
new file mode 100644
index 0000000000..79f5d24c58
--- /dev/null
+++ b/recipes/ti/matrix-gui-e_svn.bb
@@ -0,0 +1,53 @@
+DESCRIPTION = "Matrix GUI"
+HOMEPAGE = "https://gforge.ti.com/gf/project/matrix_gui/"
+LICENSE = "BSD"
+SECTION = "multimedia"
+PRIORITY = "optional"
+
+SRCREV = "57"
+PV = "1.0"
+PR = "r6+svnr${SRCPV}"
+
+SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' \
+ file://init \
+"
+
+S = "${WORKDIR}/trunk"
+
+INITSCRIPT_NAME = "matrix-gui"
+INITSCRIPT_PARAMS = "defaults 99"
+
+inherit qt4e update-rc.d
+
+MATRIX_EXTRA_BINS = " \
+ memInfo \
+ networkSettings \
+ runOGLES2Coverflow \
+ runOGLES2Shaders \
+ runOGLESChameleonMan \
+ runOGLESVase \
+ setopp1 \
+ setopp2 \
+ setopp3 \
+ setopp4 \
+ standby \
+ sysSettings \
+ taskInfo \
+"
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/matrix_gui ${D}/${bindir}
+ for i in ${MATRIX_EXTRA_BINS}; do
+ install -m 0755 ${S}/bin/${i} ${D}/${bindir}
+ done
+ install -d ${D}/${datadir}/matrix/html
+ install -m 0644 ${S}/*.html ${D}/${datadir}/matrix/html/
+ install -d ${D}/${datadir}/matrix/images
+ install -m 0644 ${S}/images/*.png ${D}/${datadir}/matrix/images/
+ install -d ${D}${sysconfdir}/init.d/
+ install -c -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-gui
+}
+
+RRECOMMENDS_${PN} = "qt4-embedded-plugin-mousedriver-tslib"
+FILES_${PN} += "${datadir}/matrix/*"