summaryrefslogtreecommitdiff
path: root/recipes/tcpdump/tcpdump_3.9.7.bb
diff options
context:
space:
mode:
authorTushar Gohad <tgohad@mvista.com>2009-07-29 22:06:39 -0700
committerChris Larson <clarson@mvista.com>2009-08-26 22:45:10 -0700
commit0b3b3824dce51d6d9585001b1e4f899bde36e95b (patch)
tree63914203ddb8b65312e9dbcfbffd565bbb33782d /recipes/tcpdump/tcpdump_3.9.7.bb
parente77453c96bcff78774c35efee8c0a9683fc552ba (diff)
tcpdump: obey distro for the ipv6 support
When cross compiling, get rid of the AC_TRY_RUN style checks for ipv6, obey DISTRO_FEATURES. Signed-off-by: Tushar Gohad <tgohad@mvista.com> Signed-off-by: Chris Larson <clarson@mvista.com>
Diffstat (limited to 'recipes/tcpdump/tcpdump_3.9.7.bb')
-rw-r--r--recipes/tcpdump/tcpdump_3.9.7.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes/tcpdump/tcpdump_3.9.7.bb b/recipes/tcpdump/tcpdump_3.9.7.bb
index 163d74f2ca..127400e399 100644
--- a/recipes/tcpdump/tcpdump_3.9.7.bb
+++ b/recipes/tcpdump/tcpdump_3.9.7.bb
@@ -5,14 +5,18 @@ SECTION = "console/network"
PRIORITY = "optional"
DEPENDS = "libpcap"
+PR = "r1"
+
SRC_URI = " \
http://www.tcpdump.org/release/tcpdump-${PV}.tar.gz \
file://tcpdump_configure_no_-O2.patch;patch=1 \
+ file://ipv6-cross.patch;patch=1 \
"
inherit autotools
-EXTRA_OECONF = "--without-crypto"
+EXTRA_OECONF = "--without-crypto \
+ ${@base_contains('DISTRO_FEATURES', 'ipv6', '--enable-ipv6', '--disable-ipv6', d)}"
do_configure() {
gnu-configize