summaryrefslogtreecommitdiff
path: root/recipes/sudo/sudo-enable-wheel-group.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-11-27 22:38:46 +0100
committerStefan Schmidt <stefan@datenfreihafen.org>2009-11-27 22:38:46 +0100
commit7b52c2df97ca766b03d0e0ecb346007d9d335105 (patch)
tree94fb6a245633c872898a185546fe351dbed59be4 /recipes/sudo/sudo-enable-wheel-group.bb
parent7fcaef86af3dc262b4c315da1b5bb5a8e012b402 (diff)
parent0e0de60f4443c143fa92068932722f5d75b0999b (diff)
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/sudo/sudo-enable-wheel-group.bb')
-rw-r--r--recipes/sudo/sudo-enable-wheel-group.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/sudo/sudo-enable-wheel-group.bb b/recipes/sudo/sudo-enable-wheel-group.bb
new file mode 100644
index 0000000000..b281ddb09d
--- /dev/null
+++ b/recipes/sudo/sudo-enable-wheel-group.bb
@@ -0,0 +1,20 @@
+PR = "r0"
+
+RDEPENDS = "sudo"
+
+ALLOW_EMPTY_${PN} = "1"
+PACKAGE_ARCH = "all"
+
+# Edit sudoers to allow the use of the wheel group and non root users to mount/shutdown etc.
+# Please consider this when using.
+
+pkg_postinst() {
+#!/bin/sh
+mkdir -p $D${sysconfdir}/
+touch $D${sysconfdir}/sudoers
+sed -i /# %wheel/d $D${sysconfdir}/sudoers
+echo '%wheel ALL=(ALL) ALL' >> $D${sysconfdir}/sudoers
+sed -i /# %users/d $D${sysconfdir}/sudoers
+echo '%users ALL=/sbin/mount /cdrom,/sbin/umount /cdrom' >> $D${sysconfdir}/sudoers
+echo '%users localhost=/sbin/shutdown -h now' >> $D${sysconfdir}/sudoers
+}