summaryrefslogtreecommitdiff
path: root/recipes/sip/sip-native_4.7.7.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/sip/sip-native_4.7.7.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/sip/sip-native_4.7.7.bb')
-rw-r--r--recipes/sip/sip-native_4.7.7.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/sip/sip-native_4.7.7.bb b/recipes/sip/sip-native_4.7.7.bb
new file mode 100644
index 0000000000..4fb4eba9e3
--- /dev/null
+++ b/recipes/sip/sip-native_4.7.7.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "SIP is a C++/Python Wrapper Generator"
+SECTION = "devel"
+HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
+AUTHOR = "Phil Thompson"
+PRIORITY = "optional"
+LICENSE = "GPL"
+PR = "ml0"
+
+SRC_URI = "http://cvs.fedora.redhat.com/repo/pkgs/sip/sip-4.7.7.tar.gz/9cabe6a0f61b73582cfc38b903576211/sip-4.7.7.tar.gz"
+S = "${WORKDIR}/sip-${PV}/sipgen"
+
+inherit qt4x11 native
+
+export BUILD_SYS
+export HOST_SYS
+export STAGING_LIBDIR
+export STAGING_INCDIR
+
+EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
+
+do_configure_prepend() {
+ cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
+}
+
+do_stage() {
+ install -m 0755 sip ${STAGING_BINDIR_NATIVE}/sip
+ cd ${WORKDIR}/sip-${PV} && python configure.py
+ install -d ${STAGING_PYDIR}/site-packages
+ install -m 0755 sip*.py ${STAGING_PYDIR}/site-packages
+}