summaryrefslogtreecommitdiff
path: root/recipes/ralink/rt3070_2.1.1.0.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-09-21 08:36:21 +0200
committerKoen Kooi <koen@openembedded.org>2009-09-21 08:36:21 +0200
commit6bc94b62f423e91dd7f3ead4b61bb7ee9608c1f1 (patch)
tree2e26d6e402cc7033d27f7647604d180e55f3eef2 /recipes/ralink/rt3070_2.1.1.0.bb
parentb4926ef1add65f61626ccffe715f535dc97bff4f (diff)
rt3070: add driver for the ralink 3070 sb wifi module, original recipe from omap3-touchbook overlay
* includes changes from http://bugzilla.alwaysinnovating.com/show_bug.cgi?id=8
Diffstat (limited to 'recipes/ralink/rt3070_2.1.1.0.bb')
-rw-r--r--recipes/ralink/rt3070_2.1.1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/ralink/rt3070_2.1.1.0.bb b/recipes/ralink/rt3070_2.1.1.0.bb
new file mode 100644
index 0000000000..d7709fa91d
--- /dev/null
+++ b/recipes/ralink/rt3070_2.1.1.0.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Ralink 3070"
+LICENSE = "GPLv2"
+
+inherit module
+
+SRC_URI = "http://www.ralinktech.com.tw/data/drivers/2009_0525_RT3070_Linux_STA_v${PV}.tar.bz2 \
+ file://makefile.patch;patch=1 \
+ file://config.patch;patch=1 \
+"
+
+EXTRA_OEMAKE = "LINUX_SRC=${STAGING_KERNEL_DIR}"
+
+S = "${WORKDIR}/2009_0525_RT3070_Linux_STA_v${PV}"
+
+do_install() {
+ mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+ cp ${S}/os/linux/rt3070sta.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless
+}