summaryrefslogtreecommitdiff
path: root/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-11-18 09:26:05 +0000
committerGraeme Gregory <dp@xora.org.uk>2009-11-18 09:26:05 +0000
commit4b517949775c8540cac9708b4981978493be9aeb (patch)
tree67f0a3f2b4ba3fce521c1ea89a72000a4aa27780 /recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb
parent15387c72d5cf1a77a5a0afa6750dae73a8dbc12f (diff)
parent19a9dfbb29d677c5cfd8b1d5af9d16409fa4bde8 (diff)
Merge branch 'org.openembedded.dev' of git+ssh://git@git.openembedded.org/openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb')
-rw-r--r--recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb b/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb
new file mode 100644
index 0000000000..7d5af472cf
--- /dev/null
+++ b/recipes/powervr-drivers/libgles-omap3_3.01.00.02.bb
@@ -0,0 +1,30 @@
+BINLOCATION = "${S}/gfx_rel_es3.x"
+
+require libgles-omap3.inc
+
+DEFAULT_PREFERENCE = "-1"
+# download required binary distribution from:
+# http://software-dl.ti.com/dsps/forms/export.html?prod_no=/OMAP35x_Graphics_SDK_setuplinux_3_01_00_02.bin
+
+SGXPV = "3_01_00_02"
+IMGPV = "1.4.14.2514"
+BINFILE := "OMAP35x_Graphics_SDK_setuplinux_${SGXPV}.bin"
+
+# The ES2.x and ES3.x CPUs have different SGX hardware, so we need to install 2 sets of userspace
+do_install_append() {
+ install -d ${D}${libdir}/ES3.0
+ install -d ${D}${libdir}/ES2.0
+ install -d ${D}${bindir}/ES3.0
+ install -d ${D}${bindir}/ES2.0
+
+ cp ${S}/gfx_rel_es2.x/lib* ${D}${libdir}/ES2.0/
+ cp ${S}/gfx_rel_es2.x//p[dv]* ${D}${bindir}/ES2.0/
+
+ cp ${D}${libdir}/lib*${IMGPV} ${D}${libdir}/ES3.0/
+ cp ${D}${bindir}/p[dv]* ${D}${bindir}/ES3.0
+}
+
+# Quality control is really poor on these SDKs, so hack around the latest madness:
+FILES_${PN} += "${libdir}/*.so "
+FILES_${PN}-dev = "${includedir}"
+