summaryrefslogtreecommitdiff
path: root/recipes/orrery/orrery_2.7.bb
diff options
context:
space:
mode:
authorSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-11 12:26:10 +0100
committerSebastian Spaeth <Sebastian@SSpaeth.de>2009-12-11 12:30:40 +0100
commit77c0cee09d8930874fabe4cb84bb636b764803d1 (patch)
tree80a50a4968d4808f259faf74cbd3ff301f712a19 /recipes/orrery/orrery_2.7.bb
parente48e6c12cb68fdc3f569b3ad80614623ef16ccca (diff)
orrery: bump 2.4 recipe to 2.7
Signed-off-by: Sebastian Spaeth <Sebastian@SSpaeth.de>
Diffstat (limited to 'recipes/orrery/orrery_2.7.bb')
-rw-r--r--recipes/orrery/orrery_2.7.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/orrery/orrery_2.7.bb b/recipes/orrery/orrery_2.7.bb
new file mode 100644
index 0000000000..7b93ee97bf
--- /dev/null
+++ b/recipes/orrery/orrery_2.7.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Astronomical application which displays the night sky"
+HOMEPAGE = "http://projects.openmoko.org/projects/orrery/"
+SECTION = "x11/scientific"
+PV = "2.7"
+PR = "r0"
+inherit autotools
+
+SRC_URI = "http://projects.openmoko.org/frs/download.php/923/orrery_2.7_clean.tar.gz;name=tarball \
+ file://orrery.png \
+ "
+
+SRC_URI[tarball.md5sum] = "bd62a33e7554ee1030313dfcdefcda8b"
+SRC_URI[tarball.sha256sum] = "645166a5e05b2064ab630534a514697fc47b681951e7fe1d635c259cbdf7a5e6"
+S = "${WORKDIR}/orrery"
+
+do_install_append() {
+ install -d ${D}${datadir}/orrery
+ cp -a ${S}/data/* ${D}${datadir}/orrery
+ install -d ${D}${datadir}/icons
+ install -m 0755 ${WORKDIR}/orrery.png ${D}${datadir}/icons
+}
+
+FILES_${PN} += "\
+ ${datadir}/icons/orrery.png"
+