summaryrefslogtreecommitdiff
path: root/recipes/orinoco/orinoco-modules_0.15rc2.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
commit6a21d65d2840c58cfa7cd749a04669d8f7980646 (patch)
tree00b1aa153b69cda8cf9406c4700fd7730c34d3a5 /recipes/orinoco/orinoco-modules_0.15rc2.bb
parentdcfe7349b369a87881cf1fa43085d9e9c5609fcf (diff)
parent6f854d71c347475d53d5080a5490625345d95d12 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/orinoco/orinoco-modules_0.15rc2.bb')
-rw-r--r--recipes/orinoco/orinoco-modules_0.15rc2.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/orinoco/orinoco-modules_0.15rc2.bb b/recipes/orinoco/orinoco-modules_0.15rc2.bb
new file mode 100644
index 0000000000..da25d7b7e5
--- /dev/null
+++ b/recipes/orinoco/orinoco-modules_0.15rc2.bb
@@ -0,0 +1,21 @@
+require orinoco-modules.inc
+
+DEPENDS = "orinoco-conf spectrum-fw"
+RDEPENDS += "orinoco-conf"
+RDEPENDS_orinoco-modules-cs += "orinoco-modules spectrum-fw"
+PR = "r10"
+
+SRC_URI += "\
+ file://makefile_fix.patch;patch=1 \
+ file://list-move.patch;patch=1 \
+ file://add_utsname.patch;patch=1 \
+ file://add_event.patch;patch=1 \
+ file://spectrum_cs_ids.patch;patch=1 \
+ file://catch-up-with-kernel-changes.patch;patch=1"
+
+do_install() {
+ install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
+ install -m 0644 *${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
+}
+
+FILES_orinoco-modules-cs = "/lib/modules/${KERNEL_VERSION}/net/*_cs${KERNEL_OBJECT_SUFFIX}"