summaryrefslogtreecommitdiff
path: root/recipes/opkg/opkg_svn.bb
diff options
context:
space:
mode:
authorStefan Schmidt <stefan@datenfreihafen.org>2009-04-23 20:28:37 +0200
committerStefan Schmidt <stefan@datenfreihafen.org>2009-04-23 20:28:37 +0200
commitf3edd2d29b7e0094db6eaa4c7d9a870a3a7d8796 (patch)
tree7b78ab96fface695033d6514bd3fba772dd7f24a /recipes/opkg/opkg_svn.bb
parent5d82a069f6c51036e79f8b7deeec3e439dae63cc (diff)
parentd9b64f479be887dc1026c747536e1fa76d28f08b (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/opkg/opkg_svn.bb')
-rw-r--r--recipes/opkg/opkg_svn.bb19
1 files changed, 3 insertions, 16 deletions
diff --git a/recipes/opkg/opkg_svn.bb b/recipes/opkg/opkg_svn.bb
index a4728970ce..749fa1e975 100644
--- a/recipes/opkg/opkg_svn.bb
+++ b/recipes/opkg/opkg_svn.bb
@@ -1,6 +1,6 @@
require opkg.inc
-PR = "r2"
+PR = "r12"
PACKAGES =+ "libopkg-dev libopkg"
@@ -13,22 +13,9 @@ OPKG_INIT_POSITION = "98"
OPKG_INIT_POSITION_slugos = "41"
pkg_postinst_${PN} () {
-#!/bin/sh
-if [ "x$D" != "x" ]; then
- install -d $D${sysconfdir}/rcS.d
- # this happens at S98 where our good 'ole packages script used to run
- echo "#!/bin/sh
-opkg-cl configure
-rm -f ${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
-" > $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
- chmod 0755 $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
-fi
-
-update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
+ update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
}
pkg_postrm_${PN} () {
-#!/bin/sh
-update-alternatives --remove opkg ${bindir}/opkg-cl
+ update-alternatives --remove opkg ${bindir}/opkg-cl
}
-