summaryrefslogtreecommitdiff
path: root/recipes/opkg/opkg-native_svn.bb
diff options
context:
space:
mode:
authorGraham Gower <graham.gower@gmail.com>2010-06-29 18:54:00 +0000
committerKhem Raj <raj.khem@gmail.com>2010-08-03 13:02:24 -0700
commit11d08db8106e173599cf5efec58d2710c66bba51 (patch)
tree8319aa1b07152198f386fb8707d2b137734caf12 /recipes/opkg/opkg-native_svn.bb
parent060285f9fdb9bc0065f119a41edb15e0182c069c (diff)
opkg recipe overhaul - removal of opkg-nogpg and opkg-nogpg-nocurl.
None of the distros in OE appear to want/need gpg or curl support in opkg; so have opkg.inc remove them by default. This diff makes things more consistent across all distros/tasks/images. The slugos recipe is kept intact and further divided from the more modern recipes. The opkg-native recipe is the sane-srcrev version even when building slugos, which should allow for changes to opkg related bbclasses without breaking the slugos build. Build tested for qemumipsel/minimal-image and nslu2/slugos-image. minimal-image builds 10% quicker in my setup and is 1mb smaller. Signed-off-by: Graham Gower <graham.gower@gmail.com> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/opkg/opkg-native_svn.bb')
-rw-r--r--recipes/opkg/opkg-native_svn.bb11
1 files changed, 1 insertions, 10 deletions
diff --git a/recipes/opkg/opkg-native_svn.bb b/recipes/opkg/opkg-native_svn.bb
index fe3ed4e7d4..33d84ff2a2 100644
--- a/recipes/opkg/opkg-native_svn.bb
+++ b/recipes/opkg/opkg-native_svn.bb
@@ -1,19 +1,10 @@
require opkg.inc
-DEPENDS = "curl-native openssl-native"
PR = "${INC_PR}"
PROVIDES =+ "virtual/update-alternatives-native"
-SRC_URI += "file://opkg-libdir.patch;maxrev=342"
-
target_libdir := "${libdir}"
inherit native
-# The nogpg version isn't getting much love and has an unused variable which trips up -Werror
-do_configure_prepend() {
- sed -i -e s:-Werror::g ${S}/libopkg/Makefile.am
-}
-
-
-EXTRA_OECONF += "--with-opkglibdir=${target_libdir} --disable-gpg"
+EXTRA_OECONF += "--with-opkglibdir=${target_libdir}"