summaryrefslogtreecommitdiff
path: root/recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb')
-rw-r--r--recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb b/recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb
new file mode 100644
index 0000000000..0961d74162
--- /dev/null
+++ b/recipes/openmoko-base/openmoko-icon-theme-standard_svn.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Standard Gtk+ icon theme for the Openmoko distribution"
+SECTION = "openmoko/base"
+PV = "0.1+svnr${SRCREV}"
+PR = "r1"
+
+inherit openmoko-base autotools
+
+SRC_URI = "${OPENMOKO_MIRROR}/src/target/${OPENMOKO_RELEASE}/artwork;module=icons;proto=http"
+S = "${WORKDIR}/icons"
+
+pkg_postinst_openmoko-icon-theme-standard () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+gtk-update-icon-cache ${datadir}/icons/openmoko-standard/
+}
+
+PACKAGE_ARCH = "all"