summaryrefslogtreecommitdiff
path: root/recipes/obsolete/xmame/xmame_0.95.bb
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2010-01-16 14:55:11 +0100
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2010-01-16 15:23:33 +0100
commitcc13f5b5773379c39262a221b2f9b4d60d64dcff (patch)
tree456078cdbcc2c3b6c7b7b39021c2c994acb19dbf /recipes/obsolete/xmame/xmame_0.95.bb
parent92037c99c1d6f28c973286317b7574a5b3c50b71 (diff)
xmame: move oldest and unfetchable entries to obsolete/
Diffstat (limited to 'recipes/obsolete/xmame/xmame_0.95.bb')
-rw-r--r--recipes/obsolete/xmame/xmame_0.95.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/obsolete/xmame/xmame_0.95.bb b/recipes/obsolete/xmame/xmame_0.95.bb
new file mode 100644
index 0000000000..80924ef0c6
--- /dev/null
+++ b/recipes/obsolete/xmame/xmame_0.95.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Multiple Arcade Machine Emulator based on SDL"
+LICENSE = "xmame"
+SECTION = "games"
+PRIORITY = "optional"
+DEPENDS = "expat virtual/libsdl libsdl-mixer"
+
+SRC_URI = "http://x.mame.net/download/historic/${P}.tar.bz2"
+
+inherit flow-lossage
+
+EXTRA_OEMAKE=
+
+do_compile() {
+ oe_runmake TARGET=mame JOY_SDL=1 SOUND_SDL=1 DISPLAY_METHOD=SDL \
+ CC="${CC}" CXX="${CXX}" CFLAGS="-I. -Isrc -Isrc/include -Isrc/unix ${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" LD="${CC}" LDFLAGS="${LDFLAGS}" \
+ RANLIB="${RANLIB}" MY_CPU="${TARGET_ARCH}" ARCH="${TARGET_OS}" \
+ GLLIBS="" STRIP="${STRIP}" AR="${AR}"
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 xmame.SDL ${D}${bindir}
+}
+