summaryrefslogtreecommitdiff
path: root/recipes/numptyphysics/numptyphysics_svn.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/numptyphysics/numptyphysics_svn.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/numptyphysics/numptyphysics_svn.bb')
-rw-r--r--recipes/numptyphysics/numptyphysics_svn.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes/numptyphysics/numptyphysics_svn.bb b/recipes/numptyphysics/numptyphysics_svn.bb
new file mode 100644
index 0000000000..d8247b588a
--- /dev/null
+++ b/recipes/numptyphysics/numptyphysics_svn.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Numpty Physics is a drawing puzzle game in the spirit (and style?) \
+of Crayon Physics using the same excellent Box2D engine."
+DEPENDS = "virtual/libsdl libsdl-image libpng"
+RDEPENDS += "libpng"
+LICENSE = "GPL"
+HOMEPAGE = "http://numptyphysics.garage.maemo.org/"
+SECTION = "x11/games"
+PV = "0.2+svnr${SRCREV}"
+PR = "r1"
+
+inherit autotools
+
+SRC_URI = "\
+# Maemo garage is sadly only available with https. Can make you trouble while fetching without accepting the certificate.
+ svn://garage.maemo.org/svn/${PN};module=trunk;proto=https \
+ http://wwwpub.zih.tu-dresden.de/~mkluge/numptyphysics_setup.tgz \
+ file://replay_off.patch;patch=1;pnum=0 \
+ file://next.png \
+ file://keyb.patch;patch=1;pnum=0 \
+ file://keyb.png \
+ file://faster.patch;patch=1;pnum=0 \
+ file://numptyphysics.desktop \
+"
+S = "${WORKDIR}/trunk"
+
+EXTRA_S = "${WORKDIR}/local/packages/numptyphysics"
+
+do_configure_append() {
+ mv ../next.png data
+ mv ../keyb.png data
+}
+
+do_install_append() {
+ install -d ${D}${datadir}/numptyphysics
+ install -d ${D}${datadir}/pixmaps
+ install -d ${D}${datadir}/applications
+ install -m 0644 ${EXTRA_S}/star.png ${D}${datadir}/pixmaps
+ install -m 0644 ../numptyphysics.desktop ${D}/${datadir}/applications
+ cp -a ${EXTRA_S}/data/* data/keyb.png ${D}/${datadir}/numptyphysics/
+}
+
+FILES_${PN} += "${datadir}"