summaryrefslogtreecommitdiff
path: root/recipes/ncftp/ncftp_3.2.0.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/ncftp/ncftp_3.2.0.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/ncftp/ncftp_3.2.0.bb')
-rw-r--r--recipes/ncftp/ncftp_3.2.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/ncftp/ncftp_3.2.0.bb b/recipes/ncftp/ncftp_3.2.0.bb
new file mode 100644
index 0000000000..23c01cf109
--- /dev/null
+++ b/recipes/ncftp/ncftp_3.2.0.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "A sophisticated console ftp client"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "ClarifiedArtistic"
+
+SRC_URI = "ftp://ftp.ncftp.com/ncftp/older_versions/ncftp-${PV}-src.tar.bz2 \
+ file://acinclude.m4 \
+ file://make.patch;patch=1 \
+ file://fixes.patch;patch=1"
+
+inherit autotools
+
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/acinclude.m4 acinclude.m4
+}
+
+INHIBIT_AUTO_STAGE = "1"
+
+do_install () {
+ install -d ${D}${bindir} ${D}${sysconfdir} ${D}${mandir}
+ oe_runmake 'prefix=${D}${prefix}' 'BINDIR=${D}${bindir}' \
+ 'SYSCONFDIR=${D}${sysconfdir}' 'mandir=${D}${mandir}' \
+ install
+}