summaryrefslogtreecommitdiff
path: root/recipes/mupdf/mupdf_0.6.bb
diff options
context:
space:
mode:
authorDmitry Artamonow <mad_soft@inbox.ru>2010-06-23 07:00:38 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-08-20 08:37:58 +0200
commitcf8d370464b68cd1ccbb2be9b93833c20ad1cfa4 (patch)
tree5324e274eacf88b915c37cfe5912f3d47bf3e668 /recipes/mupdf/mupdf_0.6.bb
parent78c84d68c9d4f5034651ec3def7d65e10bc3c480 (diff)
mupdf-0.6: new recipe
MuPDF is a slim and fast PDF viewer/toolkit. Signed-off-by: Dmitry Artamonow <mad_soft@inbox.ru> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'recipes/mupdf/mupdf_0.6.bb')
-rw-r--r--recipes/mupdf/mupdf_0.6.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/recipes/mupdf/mupdf_0.6.bb b/recipes/mupdf/mupdf_0.6.bb
new file mode 100644
index 0000000000..bcd853419b
--- /dev/null
+++ b/recipes/mupdf/mupdf_0.6.bb
@@ -0,0 +1,60 @@
+DESCRIPTION = "A lightweight PDF viewer and toolkit written in portable C."
+HOMEPAGE = "http://www.mupdf.com"
+SECTION = "x11/applications"
+LICENSE = "GPLv3"
+PR = "r0"
+
+DEPENDS = "openjpeg jbig2dec jpeg zlib virtual/libx11 libxext freetype"
+
+SRC_URI = "http://mupdf.com/download/source/${PN}-${PV}-source.tar.gz \
+ file://mupdf_fix_endianness.patch \
+ file://Makerules"
+
+S = "${WORKDIR}/mupdf"
+
+PACKAGES =+ "${PN}-tools ${PN}-tools-doc "
+FILES_${PN}-tools = "${bindir}/pdfclean ${bindir}/pdfdraw ${bindir}/pdfshow \
+ ${bindir}/pdfextract ${bindir}/pdfinfo"
+FILES_${PN}-tools-doc = "${mandir}/man1/pdfclean.1 ${mandir}/man1/pdfdraw.1 \
+ ${mandir}/man1/pdfshow.1"
+
+# mupdf crashes (at least on arm) when built with high level of optimization
+# so we need to provide some safe settings
+FULL_OPTIMIZATION = "-O2"
+
+do_configure() {
+ cp ${WORKDIR}/Makerules ${S}/Makerules
+
+ # we don't include CJK fonts to make binary more slim
+ # comment out following two lines if you need support for CJK
+ sed -i 's:^\t\$.GENDIR./font_cjk.c::g' ${S}/Makefile
+ echo "CFLAGS += -DNOCJK" >> ${S}/Makerules
+}
+
+do_compile() {
+ # mupdf uses couple of tools for code generation during build process
+ # so we need to compile them first with host compiler
+ unset CFLAGS LDFLAGS
+ oe_runmake build/debug
+ oe_runmake build/debug/cmapdump LD=${BUILD_CC} CC=${BUILD_CC}
+ oe_runmake build/debug/fontdump LD=${BUILD_CC} CC=${BUILD_CC}
+
+ # ...and then we fire 'make', feeding proper
+ # cross-compilation flags through Makerules file
+ echo "CFLAGS += ${CFLAGS}" >> ${S}/Makerules
+ echo "LDFLAGS += ${LDFLAGS}" >> ${S}/Makerules
+ oe_runmake LD="${CC}"
+}
+
+do_install() {
+ oe_runmake install prefix="${D}/usr"
+ install -d ${D}/${datadir}/applications
+ install -d ${D}/${datadir}/pixmaps
+ install -d ${D}/${mandir}/man1
+ install -m 0644 ${S}/debian/mupdf.xpm ${D}/${datadir}/pixmaps/
+ install -m 0644 ${S}/debian/mupdf.desktop ${D}/${datadir}/applications/
+ install -m 0644 ${S}/debian/*.1 ${D}/${mandir}/man1/
+}
+
+SRC_URI[md5sum] = "d1e1a1df8fb3e4d1c601506797b75036"
+SRC_URI[sha256sum] = "6f87c4f113ee9e0f4bdfd3a316ef44052edc4febc8f7b531c4a3f44ffe149605"