summaryrefslogtreecommitdiff
path: root/recipes/misc-binary-only/tda1004x-firmware.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/misc-binary-only/tda1004x-firmware.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/misc-binary-only/tda1004x-firmware.bb')
-rw-r--r--recipes/misc-binary-only/tda1004x-firmware.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/misc-binary-only/tda1004x-firmware.bb b/recipes/misc-binary-only/tda1004x-firmware.bb
new file mode 100644
index 0000000000..1e4d68532f
--- /dev/null
+++ b/recipes/misc-binary-only/tda1004x-firmware.bb
@@ -0,0 +1,38 @@
+SECTION = "base"
+DEPENDS = "unzip-native"
+
+SRC_URI = "http://hauppauge.lightpath.net/de/nova-pci218c.exe"
+FILES_${PN} = '*'
+
+python do_unpack() {
+ import re
+
+ localdata = bb.data.createCopy(d)
+ overrides = bb.data.getVar('OVERRIDES', localdata, 1)
+ if not overrides:
+ raise bb.build.FuncFailed('OVERRIDES not defined')
+ bb.data.setVar('OVERRIDES', overrides+':'+bb.data.getVar('PN', localdata, 1), localdata)
+
+ bb.data.update_data(localdata)
+
+ src_uri = bb.data.getVar('SRC_URI', localdata)
+ if not src_uri:
+ return
+ src_uri = bb.data.expand(src_uri, localdata)
+
+ local = bb.data.expand(bb.fetch.localpath(src_uri, localdata), localdata)
+ # dont need any parameters for extraction, strip them off
+ local = re.sub(';.*$', '', local)
+ bindir = bb.data.getVar('STAGING_BINDIR_NATIVE', localdata, 1)
+ cmd = '%s/unzip %s' % (bindir, local)
+ if not os.path.exists(bb.data.getVar('S', localdata, 1)):
+ os.mkdir(bb.data.getVar('S', localdata, 1))
+ os.chdir(bb.data.getVar('S', localdata, 1))
+ bb.note("Unpacking %s to %s/" % (local, os.getcwd()))
+ ret = os.system(cmd)
+}
+
+do_install() {
+ install -d ${D}${prefix}/lib/hotplug/firmware
+ install -m 0644 software/OEM/PCI/App/ttlcdacc.dll ${D}${prefix}/lib/hotplug/firmware/tda1004x.bin
+}