summaryrefslogtreecommitdiff
path: root/recipes/minipredict/dictionary_en-GB.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/minipredict/dictionary_en-GB.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/minipredict/dictionary_en-GB.bb')
-rw-r--r--recipes/minipredict/dictionary_en-GB.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/minipredict/dictionary_en-GB.bb b/recipes/minipredict/dictionary_en-GB.bb
new file mode 100644
index 0000000000..223ab23f20
--- /dev/null
+++ b/recipes/minipredict/dictionary_en-GB.bb
@@ -0,0 +1,25 @@
+inherit update-alternatives
+
+DESCRIPTION = "Dictionary file for libdictionary"
+DEPENDS = "zip-native perl-native"
+SECTION = "gpe"
+PRIORITY = "optional"
+
+SRC_URI = "http://ftp.services.openoffice.org/pub/OpenOffice.org/contrib/dictionaries/en_GB.zip"
+
+ALTERNATIVE_NAME = "dictionary"
+ALTERNATIVE_LINK = "${datadir}/dictionary/dictionary"
+ALTERNATIVE_PATH = "${datadir}/dictionary/en_GB"
+ALTERNATIVE_PRIORITY = "50"
+
+do_compile() {
+ perl -ne ' s,/.*,,; next if ( /[.1-9]/ || /^.{0,1}$/ ); print;' ${WORKDIR}/en_GB.dic | sort > en_GB
+}
+
+FILES_${PN} = "${datadir}/dictionary"
+
+do_install() {
+ install -d ${D}/${datadir}/dictionary
+ install ${S}/en_GB ${D}/${datadir}/dictionary/
+}
+