summaryrefslogtreecommitdiff
path: root/recipes/man/man_1.5p.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/man/man_1.5p.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/man/man_1.5p.bb')
-rw-r--r--recipes/man/man_1.5p.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/recipes/man/man_1.5p.bb b/recipes/man/man_1.5p.bb
new file mode 100644
index 0000000000..e46b5b03cc
--- /dev/null
+++ b/recipes/man/man_1.5p.bb
@@ -0,0 +1,41 @@
+LICENSE = "GPL"
+SECTION = "base"
+DESCRIPTION = "The man page suite, including man, apropos, \
+and whatis consists of programs that are used to read most \
+of the documentation available on a Linux system."
+PR = "r3"
+RDEPENDS_${PN} = "less groff"
+
+# Note: The default man.conf uses wrong names for GNU eqn and troff,
+# so we install our own
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/utils/man/man-${PV}.tar.bz2 \
+ file://man.conf"
+
+# Disable parallel make or it tries to link objects before they are built
+PARALLEL_MAKE = ""
+
+EXTRA_OEMAKE = ""
+GS = "-DGREPSILENT=\"q\""
+DEFS = "-DUSG -DDO_COMPRESS ${GS}"
+
+do_configure() {
+ # this doesn't support cross compilation, so it generates a
+ # bogus configuration
+ ./configure -d -confdir ${sysconfdir}
+}
+
+do_compile() {
+ # this fixes up the cross compilation by killing the bogus DEFS
+ (cd src; ${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS} \
+ makemsg.c -o makemsg)
+ oe_runmake 'DEFS=${DEFS}'
+}
+
+do_install() {
+ oe_runmake 'PREFIX=${D}' 'DEFS=${DEFS}' install
+ install -m 644 ${FILESDIR}/man.conf ${D}/etc
+}
+
+FILES_${PN} = "${bindir}/* ${sbindir} ${libexecdir} ${libdir}/lib*.so.* \
+ ${libdir}/*/ ${sysconfdir} ${sharedstatedir} ${localstatedir} \
+ /bin /sbin /lib/*/ /lib/*.so*"