summaryrefslogtreecommitdiff
path: root/recipes/lyx/lyx_1.6.4.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-10-23 09:17:37 +0200
committerKoen Kooi <koen@openembedded.org>2009-10-23 09:17:37 +0200
commitdf4e832331953c2f441ee2449cbb2b8a268c776d (patch)
tree62cd4426b42737fe223bf55d16482f72487f8b10 /recipes/lyx/lyx_1.6.4.1.bb
parenta47b5b92afb708a6b79a568d96219f839e32de55 (diff)
lyx: add 1.6.4.1
Deleting libtool.m4 allows us to use autoreconf :)
Diffstat (limited to 'recipes/lyx/lyx_1.6.4.1.bb')
-rw-r--r--recipes/lyx/lyx_1.6.4.1.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes/lyx/lyx_1.6.4.1.bb b/recipes/lyx/lyx_1.6.4.1.bb
new file mode 100644
index 0000000000..8f37ceeddc
--- /dev/null
+++ b/recipes/lyx/lyx_1.6.4.1.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "LyX is an advanced type setting processor - a frontend for LaTeX"
+SECTION = "x11/office"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.lyx.org"
+DEPENDS = "qt4-x11-free"
+RSUGGESTS = "tetex"
+RDEPENDS = "python-shell python-textutils"
+
+SRC_URI = "\
+ ftp://ftp.lyx.org/pub/lyx/stable/1.6.x/lyx-${PV}.tar.bz2 \
+ file://no-session-manager.patch;patch=1 \
+ file://qt4tools-detect.diff;patch=1 \
+"
+
+inherit qt4x11 autotools
+
+EXTRA_OECONF = "\
+ --with-qt4-dir=${QTDIR} \
+ --enable-threads=posix \
+"
+
+do_configure_prepend() {
+ rm -f ${S}/config/libtool.m4
+}
+
+EXTRA_QMAKEVARS_POST = "DEFINES+=_LIBC"
+PARALLEL_MAKE = ""
+