summaryrefslogtreecommitdiff
path: root/recipes/linux/linux-xxs1500_2.4.21.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/linux/linux-xxs1500_2.4.21.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/linux/linux-xxs1500_2.4.21.bb')
-rw-r--r--recipes/linux/linux-xxs1500_2.4.21.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/linux/linux-xxs1500_2.4.21.bb b/recipes/linux/linux-xxs1500_2.4.21.bb
new file mode 100644
index 0000000000..b4fab93669
--- /dev/null
+++ b/recipes/linux/linux-xxs1500_2.4.21.bb
@@ -0,0 +1,29 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for mycable xxs1500"
+LICENSE = "GPL"
+KV = "2.4.21"
+PV = "${KV}"
+
+SRC_URI = "http://mycable.de/xxs1500/cms/index.php?download=linux-2.4.21-20040514.1522.tgz \
+ file://Makefile \
+ file://defconfig-xxs1500 \
+ file://zboot-Makefile-flags.diff;patch=1;pnum=0"
+
+S = "${WORKDIR}/linux"
+
+inherit kernel
+
+COMPATIBLE_MACHINE = "xxs1500"
+
+PACKAGE_ARCH = "xxs1500"
+ARCH = "mips"
+KERNEL_OUTPUT = "arch/mips/zboot/images/xxs1500.flash.srec"
+KERNEL_IMAGETYPE = "zImage.flash"
+KERNEL_IMAGEDEST = "tmp"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig-xxs1500 ${S}/.config
+ cp ${WORKDIR}/Makefile ${S}/arch/mips
+}
+
+FILES_kernel += " /tmp"