summaryrefslogtreecommitdiff
path: root/recipes/libtiff/tiff_3.7.2.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
commit6a21d65d2840c58cfa7cd749a04669d8f7980646 (patch)
tree00b1aa153b69cda8cf9406c4700fd7730c34d3a5 /recipes/libtiff/tiff_3.7.2.bb
parentdcfe7349b369a87881cf1fa43085d9e9c5609fcf (diff)
parent6f854d71c347475d53d5080a5490625345d95d12 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/libtiff/tiff_3.7.2.bb')
-rw-r--r--recipes/libtiff/tiff_3.7.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/libtiff/tiff_3.7.2.bb b/recipes/libtiff/tiff_3.7.2.bb
new file mode 100644
index 0000000000..1f28e718bc
--- /dev/null
+++ b/recipes/libtiff/tiff_3.7.2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "This software provides support for the Tag Image File Format (TIFF)"
+LICENSE = ""
+HOMEPAGE = "http://www.remotesensing.org/libtiff/"
+DEPENDS = "zlib jpeg lzo"
+PR = "r4"
+
+SRC_URI = "http://dl.maptools.org/dl/libtiff/old/tiff-${PV}.tar.gz \
+ file://configure.patch;patch=1"
+
+inherit autotools
+
+do_stage() {
+ autotools_stage_includes
+ install -d ${STAGING_LIBDIR}
+ oe_libinstall -C libtiff -a -so libtiff ${STAGING_LIBDIR}
+ oe_libinstall -C libtiff -a -so libtiffxx ${STAGING_LIBDIR}
+
+}
+
+PACKAGES =+ "tiffxx tiffxx-dbg tiffxx-dev tiff-utils tiff-utils-dbg"
+FILES_tiffxx = "${libdir}/libtiffxx.so.*"
+FILES_tiffxx-dev = "${libdir}/libtiffxx.so ${libdir}/libtiffxx.*a"
+FILES_tiffxx-dbg += "${libdir}/.debug/libtiffxx.so*"
+FILES_tiff-utils = "${bindir}/*"
+FILES_tiff-utils-dbg += "${bindir}/.debug/"