summaryrefslogtreecommitdiff
path: root/recipes/libsdl/libsdl-mixer_1.2.10.bb
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-11-12 03:08:38 +0300
committerDmitry Eremin-Solenikov <dbaryshkov@gmail.com>2009-11-12 03:08:38 +0300
commitde8ffe4113d99413430db87830837042920a3ed9 (patch)
tree75436606c5fea6876dc0464965db02448b27e70d /recipes/libsdl/libsdl-mixer_1.2.10.bb
parentbf132a8996db2e75ce4d9e754ea50fa487c52160 (diff)
parent98c4cef80ccac7e109e8479ac3902b6ef24ff16f (diff)
Merge commit 'origin/org.openembedded.dev' into org.openembedded.dev
Diffstat (limited to 'recipes/libsdl/libsdl-mixer_1.2.10.bb')
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.10.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/libsdl/libsdl-mixer_1.2.10.bb b/recipes/libsdl/libsdl-mixer_1.2.10.bb
new file mode 100644
index 0000000000..1a9e808c52
--- /dev/null
+++ b/recipes/libsdl/libsdl-mixer_1.2.10.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Simple DirectMedia Layer mixer library."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libmikmod libvorbis"
+LICENSE = "LGPL"
+
+DEFAULT_PREFERENCE = "-1"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_mixer-${PV}"
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+inherit autotools_stage
+
+EXTRA_OECONF = "--disable-music-mp3"
+# although we build smpeg... need to find out how
+# to deal with optional dependencies
+
+do_compile() {
+ # Override SDL_LIBS to include a linker rpath so the linker
+ # can find the correct libdl.so when it links playwave to
+ # libSDL_mixer.so.
+ oe_runmake SDL_LIBS="$(pkg-config sdl --libs) -Wl,-rpath-link,${STAGING_LIBDIR}"
+}