summaryrefslogtreecommitdiff
path: root/recipes/libaio/libaio_0.3.103.bb
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /recipes/libaio/libaio_0.3.103.bb
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'recipes/libaio/libaio_0.3.103.bb')
-rw-r--r--recipes/libaio/libaio_0.3.103.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes/libaio/libaio_0.3.103.bb b/recipes/libaio/libaio_0.3.103.bb
new file mode 100644
index 0000000000..1453599855
--- /dev/null
+++ b/recipes/libaio/libaio_0.3.103.bb
@@ -0,0 +1,37 @@
+# libaio .bb build file
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see /COPYING)
+
+DESCRIPTION="Asynchronous input/output library that uses the kernels native interface"
+HOMEPAGE="https://rhn.redhat.com/errata/RHBA-2005-085.html"
+LICENSE="GPL"
+
+SRC_URI="http://search.belnet.be/packages/lineox/4.0/updates/SRPMS/${P}-3.src.rpm \
+file://${P}-more-arches.patch;patch=1"
+
+S="${WORKDIR}/${P}"
+
+FILES_${PN} = "/usr"
+
+inherit kernel-arch
+
+DEPENDS_append = " rpm2cpio-native"
+
+do_unpack() {
+
+ if ! test -f libaio-${PV}.tar.gz ; then
+ rpm2cpio.pl ${DL_DIR}/${P}-3.src.rpm | cpio -i --make-directories
+ tar xzvf libaio-${PV}.tar.gz
+ fi
+}
+
+do_stage () {
+ #make install prefix='${STAGING_DIR_TARGET}${layout_prefix}'
+ install -D -m 644 src/libaio.h ${STAGING_INCDIR}/libaio.h
+ oe_libinstall -so -C src libaio ${STAGING_LIBDIR}
+
+}
+
+do_install () {
+ make install prefix='${D}/usr'
+}