summaryrefslogtreecommitdiff
path: root/recipes/gnome/libgweather_2.26.0.bb
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2009-04-02 19:45:18 +0000
committerutx@penguin.cz <utx@penguin.cz>2009-04-02 19:45:18 +0000
commit7de2f107cf18ed77f9eaa0a5a7d6a07b552ce7af (patch)
treeecef2e6c40748def7d5cc68fdedf4a4674ece55b /recipes/gnome/libgweather_2.26.0.bb
parent9c67c93114222bc6a33e653c21a1fa71a5d65e5e (diff)
parentbc4bf696b52c62c68c58c41daffa2aa1c3949492 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/gnome/libgweather_2.26.0.bb')
-rw-r--r--recipes/gnome/libgweather_2.26.0.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/gnome/libgweather_2.26.0.bb b/recipes/gnome/libgweather_2.26.0.bb
new file mode 100644
index 0000000000..f36dbbdec7
--- /dev/null
+++ b/recipes/gnome/libgweather_2.26.0.bb
@@ -0,0 +1,25 @@
+LICENSE = "LGPL"
+DEPENDS = "libgnome libsoup-2.4 gtk+"
+
+inherit gnome
+
+do_configure_prepend() {
+ sed -i -e s:help:: ${S}/Makefile.am
+}
+
+
+PACKAGES =+ "libpanel-applet"
+FILES_libpanel-applet = "${libdir}/libpanel-applet-2.so.*"
+
+FILES_${PN} =+ "${datadir}/gnome* \
+ ${datadir}/icons"
+
+do_configure_prepend() {
+ sed -i -e 's: doc : :g' ${S}/Makefile.am
+}
+
+EXTRA_OEMAKE = "ORBIT_IDL=${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+do_stage() {
+ autotools_stage_all
+}