summaryrefslogtreecommitdiff
path: root/recipes/gd/gd_2.0.35+2.0.36rc1.bb
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2010-03-02 00:22:40 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2010-03-02 00:25:23 +0100
commit32b8772ca7061c1c26ec499c4cbf1a7bf5f1073c (patch)
treef32dbe0dc04d826f145f921d1d7fcd5f7b081416 /recipes/gd/gd_2.0.35+2.0.36rc1.bb
parenta68d07365b49d352b775eef410026eccfc71029b (diff)
gd: Upgrade from 2.0.33 to 2.0.36RC1
* Move the checksums into the recipe * Pick 2.0.35+2.0.36rc1 as the name to remain easily upgradable * This should resolve: http://portaudit.FreeBSD.org/6e099997-25d8-11dc-878b-000c29c5647f.html http://portaudit.FreeBSD.org/4e8344a3-ca52-11de-8ee8-00215c6a37bb.html
Diffstat (limited to 'recipes/gd/gd_2.0.35+2.0.36rc1.bb')
-rw-r--r--recipes/gd/gd_2.0.35+2.0.36rc1.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/gd/gd_2.0.35+2.0.36rc1.bb b/recipes/gd/gd_2.0.35+2.0.36rc1.bb
new file mode 100644
index 0000000000..efba70e9d5
--- /dev/null
+++ b/recipes/gd/gd_2.0.35+2.0.36rc1.bb
@@ -0,0 +1,33 @@
+SECTION = "libs"
+LICENSE = "GD"
+DESCRIPTION = "gd is a library used to create PNG, JPEG, or WBMP images."
+DEPENDS = "libpng jpeg zlib"
+PR = "r2"
+
+SRC_URI = "http://www.libgd.org/releases/gd-2.0.36RC1.tar.gz;name=src"
+SRC_URI[src.md5sum] = "39ac48e6d5e0012a3bd2248a0102f209"
+SRC_URI[src.sha256sum] = "dd7c1795271221b9237769b96b8cec7fbdc5db7b8954d864ead51fc1296a6ac8"
+
+S = "${WORKDIR}/gd-2.0.36RC1"
+
+inherit autotools binconfig gettext
+
+EXTRA_OECONF += " --with-zlib=${STAGING_LIBDIR}/.. \
+ --with-png=${STAGING_LIBDIR}/.. \
+ --with-jpeg=${STAGING_LIBDIR}/.. \
+ --without-freetype \
+ --without-fontconfig \
+ --without-xpm \
+ --without-x"
+
+EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"'
+
+headers = "gd.h gdcache.h gd_io.h gdfx.h gdfontmb.h \
+ gdfontg.h gdfontl.h gdfonts.h gdfontt.h"
+
+do_stage () {
+ oe_libinstall -so -a libgd ${STAGING_LIBDIR}/
+ for i in ${headers}; do
+ install -m 0644 $i ${STAGING_INCDIR}/
+ done
+}