summaryrefslogtreecommitdiff
path: root/recipes/e17/exalt_svn.bb
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2009-11-04 11:48:39 +0000
committerGraeme Gregory <dp@xora.org.uk>2009-11-04 11:48:39 +0000
commit4b5a2ca27aeadda74fc48931e2a0e66ddb4ced5b (patch)
treeb88a6875af3ddbc7c61d90e3302f21e1221214f8 /recipes/e17/exalt_svn.bb
parent6ccc0b7bd8208c36ed7f581c0f9e45df7e686468 (diff)
parent2f0ed0594046903fb8033852e05a0de6b1f02914 (diff)
Merge branch 'org.openembedded.dev' of git+ssh://git@git.openembedded.org/openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/e17/exalt_svn.bb')
-rw-r--r--recipes/e17/exalt_svn.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/recipes/e17/exalt_svn.bb b/recipes/e17/exalt_svn.bb
new file mode 100644
index 0000000000..8868296736
--- /dev/null
+++ b/recipes/e17/exalt_svn.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Exalt is a network manager for the windows manager Enlightenment DR17."
+HOMEPAGE = "http://watchwolf.fr/wiki/doku.php?id=exalt"
+
+LICENSE = "LGPLv2"
+DEPENDS = "elementary vpnc wpa-supplicant ecore eet edbus"
+RDEPENDS = "vpnc wpa-supplicant"
+
+PV = "0.9+svnr${SRCREV}"
+
+inherit e
+
+EXTRA_OECONF = " \
+--with-wpa_supplicant=${sbindir}/wpa_supplicant \
+--with-vpnc=${sbindir}/vpnc \
+--with-vpnc-disconnect=${sbindir}/vpnc-disconnect \
+"
+
+do_install_append() {
+ # install dbus config file
+ install -d ${D}${sysconfdir}/dbus-1/system.d/
+ install -m 0644 data/daemon/dbus/exalt.conf ${D}${sysconfdir}/dbus-1/system.d/exalt.conf
+
+ # install dbus service file
+ install -d ${D}${datadir}/dbus-1/system-services/
+ install -m 0644 org.e.Exalt.service ${D}${datadir}/dbus-1/system-services/
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+FILES_${PN} += "${datadir}/dbus-1"
+