summaryrefslogtreecommitdiff
path: root/recipes/dvsdk/ti-sdma-module_2.23.1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-06-16 16:08:09 +0200
committerKoen Kooi <koen@openembedded.org>2009-06-16 16:08:09 +0200
commit8687813463bc7c9f37349000f75cfc0967da8458 (patch)
treeeb550c22da7a2d9b35c64aee09172bd9d117c098 /recipes/dvsdk/ti-sdma-module_2.23.1.bb
parentd895433b6c50e46edd9a75ed512455513f8e00df (diff)
dvsdk: sync with TI overlay (http://arago-project.org/git/people/?p=brijesh/arago-dvsdk.git;a=summary)
* cleanups will follow later
Diffstat (limited to 'recipes/dvsdk/ti-sdma-module_2.23.1.bb')
-rw-r--r--recipes/dvsdk/ti-sdma-module_2.23.1.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes/dvsdk/ti-sdma-module_2.23.1.bb b/recipes/dvsdk/ti-sdma-module_2.23.1.bb
new file mode 100644
index 0000000000..924a61866a
--- /dev/null
+++ b/recipes/dvsdk/ti-sdma-module_2.23.1.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "SDMA module for TI OMAP3 processors"
+
+inherit module
+# compile and run time dependencies
+DEPENDS = "virtual/kernel perl-native"
+
+PR = "r9"
+PV = "2231"
+
+SRC_URI = "http://install.source.dir.com/codec_engine_2_23_01.tar.gz "
+
+# Set the source directory
+S = "${WORKDIR}/codec_engine_2_23_01"
+
+do_compile() {
+ # SDMA - Build the sdma module
+ # TODO :: KERNEL_CC, etc need replacing with user CC
+ # TODO :: Need to understand why OBJDUMP is required for kernel module
+ # Unset these since LDFLAGS gets picked up and used incorrectly.... need
+ # investigation
+
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+
+ cd ${S}/cetools/packages/ti/sdo/linuxutils/sdma
+ make \
+ LINUXKERNEL_INSTALL_DIR="${STAGING_KERNEL_DIR}" \
+ MVTOOL_PREFIX="${TARGET_PREFIX}" \
+ UCTOOL_PREFIX="${TARGET_PREFIX}" \
+ clean debug release
+}
+
+do_install () {
+ install -d ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+ install -m 0755 ${S}/cetools/packages/ti/sdo/linuxutils/sdma/src/module/sdmak.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp
+}
+
+pkg_postinst () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ depmod -a
+ update-modules || true
+}
+
+pkg_postrm () {
+ update-modules || true
+}
+
+INHIBIT_PACKAGE_STRIP = "1"
+
+FILES_${PN} = "/lib/modules/${KERNEL_VERSION}/kernel/drivers/dsp/sdmak.ko"
+