summaryrefslogtreecommitdiff
path: root/recipes/dash/dash_0.5.5.1.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-08-27 00:01:45 -0700
committerKhem Raj <raj.khem@gmail.com>2009-08-27 00:01:45 -0700
commit628d887f5cf5c32c2d3f23c981f35c3cb84a4d49 (patch)
treef56e0cfb1ea2c53dac71c9308902137d421bbf3f /recipes/dash/dash_0.5.5.1.bb
parent865ed19cd318a8ca35b3dff2db8518851e00b8e2 (diff)
dash_0.5.2.bb: Add recipe for latest dash.
Remove unbuildable dash_0.5.2 recipe. Add checksums for new dash and diffstat Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'recipes/dash/dash_0.5.5.1.bb')
-rw-r--r--recipes/dash/dash_0.5.5.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/dash/dash_0.5.5.1.bb b/recipes/dash/dash_0.5.5.1.bb
new file mode 100644
index 0000000000..7a88407925
--- /dev/null
+++ b/recipes/dash/dash_0.5.5.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "The Debian Almquist Shell is a POSIX compliant shell that is much smaller than 'bash'."
+PROVIDES = "virtual/sh"
+LICENSE = "BSD GPL"
+
+SRC_URI = "http://ftp.debian.org/debian/pool/main/d/dash/dash_${PV}.orig.tar.gz \
+ http://ftp.debian.org/debian/pool/main/d/dash/dash_${PV}-2.3.diff.gz;patch=1 \
+ file://makefile-build-cc.diff;patch=1"
+
+inherit autotools
+
+bindir = "/bin"
+PREFIX="${bindir}"
+
+# dont use update-alternatives class because since we are dealing with /bin/sh
+# we need to do the remove in pkg_prerm where the /bin/sh link still points
+# to something (postrm is a shell script)
+
+ALTERNATIVE_NAME = "sh"
+ALTERNATIVE_PATH = "${bindir}/dash"
+ALTERNATIVE_PRIORITY = "10"
+ALTERNATIVE_LINK = "${bindir}/${ALTERNATIVE_NAME}"
+
+pkg_postinst() {
+update-alternatives --install ${ALTERNATIVE_LINK} ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH} ${ALTERNATIVE_PRIORITY}
+}
+
+pkg_prerm() {
+update-alternatives --remove ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH}
+}