summaryrefslogtreecommitdiff
path: root/recipes/corosync/corosync_1.2.6.bb
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2010-07-01 19:21:10 +0400
committerRoman I Khimov <khimov@altell.ru>2010-07-12 08:47:46 +0400
commitac8b14020e0f6ea4cdfd94c1db971ac9f4895f4f (patch)
tree86d6d61c537aa5bab28be5eaa9f3cc7755603824 /recipes/corosync/corosync_1.2.6.bb
parented52cfe0580e6ddce08bd2c717aed1963f2d8737 (diff)
corosync: update to version 1.2.6
* bug fix release, considered as safe upgrade Signed-off-by: Roman I Khimov <khimov@altell.ru>
Diffstat (limited to 'recipes/corosync/corosync_1.2.6.bb')
-rw-r--r--recipes/corosync/corosync_1.2.6.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes/corosync/corosync_1.2.6.bb b/recipes/corosync/corosync_1.2.6.bb
new file mode 100644
index 0000000000..0512148d2d
--- /dev/null
+++ b/recipes/corosync/corosync_1.2.6.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "OSI Certified implementation of a complete cluster engine"
+LICENSE = "BSD"
+
+PR = "r0"
+
+SRC_URI = " \
+ ftp://ftp@corosync.org/downloads/corosync-${PV}/corosync-${PV}.tar.gz \
+ file://fix-lcrso-linkage.patch \
+ file://init \
+ file://corosync.conf \
+ file://volatiles \
+ "
+SRC_URI[md5sum] = "82d91373585f0d48cb98a8599a237e48"
+SRC_URI[sha256sum] = "ad41e3133659a5fb32e878aa85199aba6cc84aa5e0e913b4f6e31c4a4805f9d9"
+
+
+inherit autotools_stage update-rc.d
+
+INITSCRIPT_NAME = "corosync-daemon"
+
+EXTRA_OECONF = "--disable-nss"
+
+FILES_${PN}-dbg += "${libexecdir}/lcrso/.debug"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install -d ${D}${sysconfdir}/default/volatiles
+ # Original init script is too bashy
+ rm -f ${D}/${sysconfdir}/init.d/corosync
+ install -m 0755 ${WORKDIR}/init ${D}/${sysconfdir}/init.d/corosync-daemon
+ install -m 0644 ${WORKDIR}/corosync.conf ${D}/${sysconfdir}/corosync/corosync.conf.example
+ install -m 0644 ${WORKDIR}/volatiles ${D}${sysconfdir}/default/volatiles/05_corosync
+}
+
+pkg_postinst_${PN} () {
+ set -e
+ grep haclient /etc/group || addgroup haclient
+ grep hacluster /etc/passwd || adduser --disabled-password --home=/var/lib/heartbeat --ingroup haclient -g "HA cluster" hacluster
+ /etc/init.d/populate-volatile.sh update
+}