summaryrefslogtreecommitdiff
path: root/recipes/autofs/autofs_4.1.4.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-19 20:56:09 +0100
commit6a21d65d2840c58cfa7cd749a04669d8f7980646 (patch)
tree00b1aa153b69cda8cf9406c4700fd7730c34d3a5 /recipes/autofs/autofs_4.1.4.bb
parentdcfe7349b369a87881cf1fa43085d9e9c5609fcf (diff)
parent6f854d71c347475d53d5080a5490625345d95d12 (diff)
Merge branch 'org.openembedded.dev' of git@git.openembedded.net:openembedded into org.openembedded.dev
Diffstat (limited to 'recipes/autofs/autofs_4.1.4.bb')
-rw-r--r--recipes/autofs/autofs_4.1.4.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/recipes/autofs/autofs_4.1.4.bb b/recipes/autofs/autofs_4.1.4.bb
new file mode 100644
index 0000000000..d9863ad9dd
--- /dev/null
+++ b/recipes/autofs/autofs_4.1.4.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Kernel based automounter for linux."
+SECTION = "base"
+LICENSE = "GPL"
+
+PR = "r2"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-${PV}.tar.bz2 \
+ ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-misc-fixes.patch;patch=1 \
+ ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-multi-parse-fix.patch;patch=1 \
+ ${KERNELORG_MIRROR}/pub/linux/daemons/autofs/v4/autofs-4.1.4-non-replicated-ping.patch;patch=1 \
+ file://cross.patch;patch=1 \
+ file://Makefile.rules-cross.patch;patch=1 \
+ file://install.patch;patch=1 \
+ file://auto.net-sort-option-fix.patch;patch=1 \
+ file://autofs-additional-distros.patch;patch=1 \
+ file://no-bash.patch;patch=1"
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "autofs"
+INITSCRIPT_PARAMS = "defaults"
+
+EXTRA_OEMAKE="TARGET_PREFIX=${TARGET_PREFIX}"
+PARALLEL_MAKE = ""
+
+do_configure_prepend () {
+ if [ ! -e acinclude.m4 ]; then
+ cp aclocal.m4 acinclude.m4
+ fi
+}
+
+do_install () {
+ oe_runmake 'INSTALLROOT=${D}' install
+}