summaryrefslogtreecommitdiff
path: root/packages/xqtlauncher
diff options
context:
space:
mode:
authorBernhard Guillon <Bernhard.Guillon@opensimpad.org>2009-02-08 14:18:28 +0100
committerBernhard Guillon <Bernhard.Guillon@opensimpad.org>2009-02-08 14:23:02 +0100
commit3f3f913285072e7016482926d3906d111237713c (patch)
treefb544f6445280f946d2ce35e4c1ef4fe505c9cc6 /packages/xqtlauncher
parentc58d95aff1f74da635b4ad2910df1f40b21bd4ce (diff)
xqtlauncher: fix convert script and bump PR
A fix path to runFOO must be set to make opie happy
Diffstat (limited to 'packages/xqtlauncher')
-rw-r--r--packages/xqtlauncher/xqtlauncher.bb2
-rwxr-xr-xpackages/xqtlauncher/xqtlauncher/xqtlauncher-convert.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/packages/xqtlauncher/xqtlauncher.bb b/packages/xqtlauncher/xqtlauncher.bb
index 043ee566e3..5fc80b1e51 100644
--- a/packages/xqtlauncher/xqtlauncher.bb
+++ b/packages/xqtlauncher/xqtlauncher.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "xqtlauncher integrates X/Qt2 nicely into opie. You can launch applications with it from opies menue"
HOMEPAGE = "http://angstrom-distribution.org/"
LICENSE = "GPL"
-PR = "r1"
+PR = "r2"
RDEPENDS = "xqt2 xorg-minimal-fonts"
diff --git a/packages/xqtlauncher/xqtlauncher/xqtlauncher-convert.sh b/packages/xqtlauncher/xqtlauncher/xqtlauncher-convert.sh
index 0356d332ff..59efad3be3 100755
--- a/packages/xqtlauncher/xqtlauncher/xqtlauncher-convert.sh
+++ b/packages/xqtlauncher/xqtlauncher/xqtlauncher-convert.sh
@@ -5,7 +5,7 @@ for i in `find /usr/share/applications -name *.desktop`; do
newfile=/usr/lib/opie/apps/XQt2/$name.desktop
if [ ! -f $newfile ] ; then
#cat $i | awk 'BEGIN {FS="="} {if ($1 == "Exec") {print "Exec=run"ENVIRON["name"]" " $2} else if ($1 == "Icon") {print "Icon=/usr/share/pixmaps/"$2} else {print $0} }' > $newfile
- cat $i | awk 'BEGIN {FS="="} {if ($1 == "Exec") {print "Exec=run"ENVIRON["name"]" " $2} else {print $0} }' > $newfile
+ cat $i | awk 'BEGIN {FS="="} {if ($1 == "Exec") {print "Exec=/usr/lib/opie/bin/run"ENVIRON["name"]" " $2} else {print $0} }' > $newfile
icon=$(cat $i | awk 'BEGIN {FS="="} {if ($1 == "Icon") {print $2} }')
ln -sf /usr/bin/xqtlauncher /usr/lib/opie/bin/run$name
#We need to make symlinks for the pics because opie can not handle pics with paths :(