summaryrefslogtreecommitdiff
path: root/packages/xorg-xserver/xserver-kdrive-1.4.2/enable-tslib.patch
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2008-06-17 16:33:47 +0000
committerPhilipp Zabel <philipp.zabel@gmail.com>2008-06-17 16:33:47 +0000
commitacb05eb37634bb4f174e08972a2d34ba867bd9b7 (patch)
tree946dd2eee4333b2c37cc516373a0a8f3d8396d55 /packages/xorg-xserver/xserver-kdrive-1.4.2/enable-tslib.patch
parent9fd5afe0d675e93df91551ba990fc62bbf0b877b (diff)
xserver-xorg, xserver-kdrive: add 1.4.2
Diffstat (limited to 'packages/xorg-xserver/xserver-kdrive-1.4.2/enable-tslib.patch')
-rw-r--r--packages/xorg-xserver/xserver-kdrive-1.4.2/enable-tslib.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/packages/xorg-xserver/xserver-kdrive-1.4.2/enable-tslib.patch b/packages/xorg-xserver/xserver-kdrive-1.4.2/enable-tslib.patch
new file mode 100644
index 0000000000..3746be5f53
--- /dev/null
+++ b/packages/xorg-xserver/xserver-kdrive-1.4.2/enable-tslib.patch
@@ -0,0 +1,24 @@
+Index: xorg-server-1.4/configure.ac
+===================================================================
+--- xorg-server-1.4.orig/configure.ac 2007-09-08 16:36:37.000000000 +0200
++++ xorg-server-1.4/configure.ac 2007-09-08 16:38:10.000000000 +0200
+@@ -1816,7 +1816,7 @@
+ AC_CHECK_LIB([rt], [nanosleep], XEPHYR_LIBS="$XEPHYR_LIBS -lrt"))
+
+ if test "x$TSLIB" = xyes; then
+- PKG_CHECK_MODULES([TSLIB], [tslib-0.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
++ PKG_CHECK_MODULES([TSLIB], [tslib-1.0], [HAVE_TSLIB="yes"], [HAVE_TSLIB="no"])
+ if test "x$HAVE_TSLIB" = xno; then
+ AC_MSG_ERROR([tslib must be installed to build the tslib driver. See http://tslib.berlios.de/])
+ fi
+@@ -1840,8 +1840,8 @@
+ ;;
+ esac
+ KDRIVE_STUB_LIB='$(top_builddir)/hw/kdrive/src/libkdrivestubs.a'
+- KDRIVE_LOCAL_LIBS="$DIX_LIB $CONFIG_LIB $KDRIVE_LIB $TSLIB_LIBS $KDRIVE_OS_LIB $KDRIVE_PURE_LIBS $KDRIVE_STUB_LIB"
+- KDRIVE_LIBS="$XSERVERLIBS_LIBS $KDRIVE_LOCAL_LIBS"
++ KDRIVE_LOCAL_LIBS="$DIX_LIB $CONFIG_LIB $KDRIVE_LIB $KDRIVE_OS_LIB $KDRIVE_PURE_LIBS $KDRIVE_STUB_LIB"
++ KDRIVE_LIBS="$XSERVERLIBS_LIBS $TSLIB_LIBS $KDRIVE_LOCAL_LIBS"
+
+ # check if we can build Xephyr
+ PKG_CHECK_MODULES(XEPHYR, x11 xext xfont xau xdmcp, [xephyr="yes"], [xephyr="no"])