summaryrefslogtreecommitdiff
path: root/packages/xfsprogs
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-08 14:33:53 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-08 14:33:53 +0100
commit0b2d8d7c37d681a249a2752a2df821bfce1f2742 (patch)
tree36ac27054b2db566242d2ee84102ac52752fea75 /packages/xfsprogs
parent45cf18b90d4a0a7802bc1fffadc4f5a42cbc9233 (diff)
libattr: created: lib to access attribute bits of a file
Diffstat (limited to 'packages/xfsprogs')
-rw-r--r--packages/xfsprogs/libattr_2.4.43.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/xfsprogs/libattr_2.4.43.bb b/packages/xfsprogs/libattr_2.4.43.bb
new file mode 100644
index 0000000000..99890313f5
--- /dev/null
+++ b/packages/xfsprogs/libattr_2.4.43.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "library functions to get attribute bits"
+HOMEPAGE = "http://oss.sgi.com/projects/xfs"
+LICENSE = "GPL"
+SECTION = "base"
+PR = "r0"
+DEPENDS = "gettext"
+
+SRC_URI = "ftp://oss.sgi.com/projects/xfs/cmd_tars/attr_${PV}-1.tar.gz"
+S = "${WORKDIR}/attr-${PV}"
+
+PARALLEL_MAKE = ""
+inherit autotools
+EXTRA_OECONF = "--enable-gettext=no --enable-shared=yes"
+
+do_configure () {
+ export LIBTOOL="${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"
+ export DEBUG="-DNDEBUG"
+ oe_runconf
+}
+
+do_install () {
+ export DIST_ROOT=${D}
+ oe_runmake install
+ oe_libinstall -a libattr ${D}${libdir}
+ oe_libinstall -a libattr ${STAGING_LIBDIR}
+}
+