summaryrefslogtreecommitdiff
path: root/packages/wrt/wrt-init.bb
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-16 17:40:11 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-06-16 17:40:11 +0000
commitdbef60af10feedfaf2be91cb250b3a8777e8af66 (patch)
tree00807f23c2121c851b5b9de6cd2e34db715bad4a /packages/wrt/wrt-init.bb
parenta30791b51c9b8ab16f31883d07288e7e9eda1339 (diff)
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/06/16 19:20:15+02:00 (none)!br1 modutils.sh: also handle cases when depmod and modprobe is not installed 2005/06/16 19:19:03+02:00 (none)!br1 wrt busybox config: add run-parts, start-stop-daemon, ifup. remove telnetd 2005/06/16 19:12:23+02:00 (none)!br1 add modutils for wrt BKrev: 42b1b97bNWtJltYtYyTXoAV0eFK0nw
Diffstat (limited to 'packages/wrt/wrt-init.bb')
-rw-r--r--packages/wrt/wrt-init.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/wrt/wrt-init.bb b/packages/wrt/wrt-init.bb
index e69de29bb2..bbb19f8c58 100644
--- a/packages/wrt/wrt-init.bb
+++ b/packages/wrt/wrt-init.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "wrt init scripts"
+SECTION = "base"
+LICENSE = "GPL"
+
+SRC_URI = "file://mount file://wrtboot"
+
+do_install() {
+ install -d ${D}${sysconfdir}/rcS.d \
+ ${D}${sysconfdir}/init.d
+
+ install -m 0755 ${WORKDIR}/mount ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/wrtboot ${D}${sysconfdir}/init.d
+
+ ln -s ../init.d/mount ${D}${sysconfdir}/rcS.d/S05mount
+ ln -s ../init.d/wrtboot ${D}${sysconfdir}/rcS.d/S10wrtboot
+}