summaryrefslogtreecommitdiff
path: root/packages/wifistix/wifistix-modules_5.0.16.p0.bb
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2007-09-29 20:43:38 +0000
committerPhilip Balister <philip@balister.org>2007-09-29 20:43:38 +0000
commitea52a2ce713343961a660f74efd5fbff95668f94 (patch)
tree4c83af5a077ed985c6ac4c73f04995c29e56ab5f /packages/wifistix/wifistix-modules_5.0.16.p0.bb
parent6feecb2942024a270c39b50d6892be3f421dcab6 (diff)
wifistix : Add driver for Marvell cf8385 wireless interface driver for gumstix.
Diffstat (limited to 'packages/wifistix/wifistix-modules_5.0.16.p0.bb')
-rw-r--r--packages/wifistix/wifistix-modules_5.0.16.p0.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/packages/wifistix/wifistix-modules_5.0.16.p0.bb b/packages/wifistix/wifistix-modules_5.0.16.p0.bb
new file mode 100644
index 0000000000..abd8a8c246
--- /dev/null
+++ b/packages/wifistix/wifistix-modules_5.0.16.p0.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Linux Driver for Marvel 88W8385 802.11b/g Wifi Module used in Gumstix daughtercards"
+SECTION = "base"
+PRIORITY = "optional"
+HOMEPAGE = "http://www.gumstix.com"
+LICENSE = "GPL"
+RDEPENDS = "kernel (${KERNEL_VERSION})"
+DEPENDS = "virtual/kernel"
+PR = "r0"
+
+SRC_URI = "http://files.gumstix.com/cf8385-5.0.16.p0-26306.tbz \
+ file://marvell-devicename.patch;patch=1 \
+ file://marvell-devicetable.patch;patch=1 \
+ file://marvell-gumstix.patch;patch=1 \
+ file://sbi-no-inline.patch;patch=1 \
+ file://2.6.17-new-pcmcia-layer.patch;patch=1 \
+ file://bad-cast.patch;patch=1 \
+ file://struct-changes.patch;patch=1 \
+ file://no-more-config-h.patch;patch=1 \
+ file://realtime-kernel.patch;patch=1 \
+ file://install-properly.patch;patch=1 \
+ file://fix-essid-truncation.patch;patch=1"
+
+S = "${WORKDIR}/src_cf8385"
+
+inherit module-base
+
+do_compile() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ make CONFIG_GUMSTIX=y CONFIG_DEBUG=n KVER=2.6 KERNELDIR="${KERNEL_SOURCE}" \
+ ARCH="${TARGET_ARCH}" CC="${KERNEL_CC}" EXTRA_CFLAGS="${CFLAGS}"
+}
+
+do_install() {
+ unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
+ make CONFIG_GUMSTIX=y CONFIG_DEBUG=n KVER=2.6 KERNELDIR="${KERNEL_SOURCE}" \
+ ARCH="${TARGET_ARCH}" CC="${KERNEL_CC}" EXTRA_CFLAGS="${CFLAGS}" INSTALL_MOD_PATH="${D}" install
+# (grep -q mcf25 ${D}/etc/modprobe.conf || \
+# echo -e 'alias mwlan0 mcf25\n' >> ${D}/etc/modprobe.conf)
+# (grep -q mwlan0 ${D}/etc/network/interfaces || \
+# echo -e '\nauto mwlan0\niface mwlan0 inet dhcp\n pre-up /sbin/iwconfig $$IFACE essid any txpower 100mW\n' >> $(TARGET_DIR)/etc/network/interfaces)
+}
+
+PACKAGES = "${PN}"
+FILES_${PN} = "/lib/modules/"